Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Das Update ist abgeschlossen, Ihr könnt unser Forum jetzt wieder wie gewohnt nutzen. Eventuelle Bugs und Auffälligkeiten postet Ihr bitte im entsprechenden Forum im Bereich Forumstechnik. x


Kostenzuordnung mit Gültigkeitsbereich
#1
Hallo Zusammen,
 
ich hoffe ihr hattet alle erholsame Weihnachten.
 
Ich stehe vor folgendem Problem:
 
Ich habe folgende Tabelle
 
Spalte E  II Spalte F  II    Spalte G II Spalte H
Müller    II 01.01.2023 II 31.01.2024 II 4€
Müller    II 01.02.2024 II 01.09.2024 II 5€
Schmidt  II 01.01.2023 II 31.01.2024 II 2€
Schmidt  II 01.02.2024 II 01.09.2024 II 3€
Schmidt    II 01.10.2024 II 31.10.2024 II 4€
 
Nun möchte ich auf eine andere Tabelle den Preis für bestimmte Daten auslesen.
 
In B10 steht nun also Schmidt und in B13 steht 15.01.2024 er soll mir jetzt den gültigen Preis aus Spalte H ausgeben, in B14 steht 01.03.2024, in B15 steht 15.10.2024 usw.



 
 
Ich hoffe, dass ihr versteht was ich meine.
 
Ich bedanke mich schonmal sehr für eure Hilfe.
 
LG
Sascha
Antworten Top
#2
Wenn Du eine aktuelle Excel Version hast, könnte man das mit der Filterfunktion erledigen.
PHP-Code:
=FILTER(INDEX($E$1:$H$5;SEQUENZ(ANZAHL2($E$1:$E$5));{4});($E$1:$E$5=$B$10)*($F$1:$F$5<=B13)*($G$1:$G$5)>=B13
Der Perfektionist ergänzt dann noch WennFehler

Es gibt sicher noch andere Formellösungen.
[-] Folgende(r) 1 Nutzer sagt Danke an Warkings für diesen Beitrag:
  • SaschaL
Antworten Top
#3
Zur Info….
https://www.herber.de/forum/archiv/1956t...reich.html
Antworten Top
#4
Darf ich das nicht in 2 Foren posten - wenn nicht - tut es mir leid.
Antworten Top
#5
Darfst du schon, nur dann auch bitte verlinken. So haben Helfer die Chance nachzuschauen, ob es schon Lösungen gibt.
Die hier von Warkings angesprochenen anderen Formeln habe ich zB im anderen Thread aufgelistet.
Antworten Top
#6
Ich nehme das meistens zum Anlass, künftige Fragen des "Anbieters" zu ignorieren.
Antworten Top
#7
Wird nicht mehr vorkommen - danke dennoch schon einmal für die Hilfe.

Werde in Zukunft darauf achten.
Antworten Top
#8
(28.12.2023, 11:18)Warkings schrieb: Wenn Du eine aktuelle Excel Version hast, könnte man das mit der Filterfunktion erledigen.
PHP-Code:
=FILTER(INDEX($E$1:$H$5;SEQUENZ(ANZAHL2($E$1:$E$5));{4});($E$1:$E$5=$B$10)*($F$1:$F$5<=B13)*($G$1:$G$5)>=B13
Der Perfektionist ergänzt dann noch WennFehler

Es gibt sicher noch andere Formellösungen.

Leider bekomme ich immer einen #Wert Fehler. Kann ich die Datei vielleicht einmal anhängen?

Vielleicht hat noch jemand eine Idee?

Danke


Angehängte Dateien
.xlsx   Test_RM Kostensatz Zuordnung Test.xlsx (Größe: 14,69 KB / Downloads: 6)
Antworten Top
#9
Ja, mit den 3 Formeln die ich angesprochen habe. Geäußert hast du dich dazu ja nicht.
=SUMMEWENNS(H2:H6;E2:E6;B10;F2:F6;"<="&B13;G2:G6;">="&B13)
=SUMMENPRODUKT((E2:E6=B10)*(F2:F6<=B13)*(G2:G6>=B13)*(H2:H6))
=INDEX(H2:H6;AGGREGAT(15;6;ZEILE(H2:H6)-1/((E2:E6=B10)*(F2:F6<=B13)*(G2:G6>=B13));1))
[-] Folgende(r) 1 Nutzer sagt Danke an steve1da für diesen Beitrag:
  • SaschaL
Antworten Top
#10
Super - vielen Dank!!
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste