Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Kombi Felder - Liste in Spalte ausgeben
#1
Hallo liebe Excel Freunde,

ich möchte eine Liste aus Abschnittsbezeichnungen automatisch ausgeben lassen.
Die Zielformel soll die erforderlichen Feldnamen aus Spalte I untereinander in eine Spalte schreiben.
Bedingungen:
- Die Anzahl der untereinander ausgegebenen Feldnamen soll abhängig von der genannten Anzahl in Spalte M sein
- für die Ausnahme "ohne Kabel" in  Spalte L soll das Feld in der Ausgabe übersprungen werden.

Eine Beispieldatei wurde angehängt.

Würde mich sehr über jede Hilfe freuen.
Gruß,
Hannes.


Angehängte Dateien
.xlsx   Kombifeld_Ausgabe.xlsx (Größe: 226,33 KB / Downloads: 10)
Antwortento top
#2
Hallöchen,

mit einem Makro ginge das so:

Code:
Option Explicit

Sub Liste()
'Variablendeklarationen
Dim iCnt1%, iCnt2%
'Startzeile festlegen
iCnt1 = 17
'Schleife solange in I kein Leereintrag auftritt
Do While Cells(iCnt1, 9).Value <> ""
  'Schleife entsprechend Anzahl aus Spalte M
  For iCnt2 = 1 To Cells(iCnt1, 13).Value
    'Eintrag aus Spalte I nach SPalte R uebernehmen
    Cells(Rows.Count, 18).End(xlUp).Offset(1).Value = Cells(iCnt1, 9).Value
  'Ende Schleife entsprechend Anzahl aus Spalte M
  Next
'Zeilenzaehler hochsetzen
iCnt1 = iCnt1 + 1
'Ende Schleife solange in I kein Leereintrag auftritt
Loop
End Sub
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • hanso686
Antwortento top
#3
Hi

Wenn du bei Formeln bleiben möchtest.
N16  =0
N17  =SUMME($M$17:M17)    'nach unten ziehen
R17  =VERWEIS(ZEILE(A1)-1;$N$16:$N$200;$I$17:$I$201)    'nach unten ziehen

Gruß Elex
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • hanso686
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste