Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Kalenderwoche in Tabelle
#1
Hallo,
ich habe einen vertikalen Monatskalender angelegt, in dem Arbeitszeiten erfasst erden sollen. 
Nun möchte ich neben der Spalte mit den Tagen jeweils neben dem Montag auch noch die Angabe der Kalenderwoche. 
Wie kann ich das erreichen? 
Danke für jede Hilfe.
Gruß,
Axel


Angehängte Dateien
.xlsx   Arbeitsstunden_&Projekte_Test.xlsx (Größe: 13,16 KB / Downloads: 11)
Antwortento top
#2
C4: =(REST(A4;7)=2)*KALENDERWOCHE(A4;21) mit benDefFmt "00";;
Antwortento top
#3
Hallo,

versuche es mal damit:

Code:
Sub kalenderwoche()
    Dim a As Integer, dat As Date
    For r = 4 To 32
        dat = Cells(r, 1)
        a = Int((dat - DateSerial(Year(dat), 1, 1) + _
            ((Weekday(DateSerial(Year(dat), 1, 1)) + 1) Mod 7) - 3) / 7) + 1
        If a = 0 Then
            a = DateSerial(Year(dat) - 1, 12, 31)
        ElseIf a = 53 And (Weekday(DateSerial(Year(dat), 12, 31)) - 1) Mod 7 <= 3 Then
            a = 1
        End If
        If Format(Cells(r, 1), "dddd") = "Montag" Then Cells(r, 3) = "KW " & a
    Next r
End Sub
Habe das auf deine Datei angepasst.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
[-] Folgende(r) 1 Benutzer sagt Danke an Klaus-Dieter für diesen Beitrag:
  • RiPolar
Antwortento top
#4
Hallo,

oder so ... viele Wege führen nach Rom ...



Februar

ABCD
12020Monat  02
2Februar
3KW
401Sa
502So
603Mo KW 6 ?? Formel ?
Formeln der Tabelle
ZelleFormel
A2=B4
A4=DATUM(A1;C1;1)
B4=A4
C4=WENN(WOCHENTAG(B4;2)=1;"KW "&KALENDERWOCHE(A4;21);"")
A5=WENNFEHLER(WENN(MONAT(A4+1)=MONAT(A$4);A4+1;““);““)
B5=A5
C5=WENN(WOCHENTAG(B5;2)=1;"KW "&KALENDERWOCHE(A5;21);"")
A6=WENNFEHLER(WENN(MONAT(A5+1)=MONAT(A$4);A5+1;““);““)
B6=A6
C6=WENN(WOCHENTAG(B6;2)=1;"KW "&KALENDERWOCHE(A6;21);"")
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A41. / Formel ist =WOCHENTAG(A4;2)>5Abc
B41. / Formel ist =WOCHENTAG(A4;2)>5Abc
A51. / Formel ist =WOCHENTAG(A4;2)>5Abc
B51. / Formel ist =WOCHENTAG(A4;2)>5Abc
A61. / Formel ist =WOCHENTAG(A4;2)>5Abc
B61. / Formel ist =WOCHENTAG(A4;2)>5Abc

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8



Gruß

Marcus

@LCohen,

Deine benutzerdefinierte Formatierung klappt bei mir nicht. Habe aber weiter getestet. Du hast wohl versehentlich Gänsefüßchen gesetzt.

Benurtzerdefinierte Formatierung bei mir:

00;;

Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#5
PHP-Code:
=IFERROR(WEEKNUM(A6;21)/(WEEKDAY(A6)=2);""
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
[-] Folgende(r) 1 Benutzer sagt Danke an snb für diesen Beitrag:
  • RiPolar
Antwortento top
#6
Stimmt, versehentlich.
Antwortento top
#7
Hallo,
wieder ein herzlichen Dank an das hervorragende Forum!

Gruß,
Axel
Antwortento top
#8
Hallo. Last but not least..:

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
101.01.2020
202.01.2020
303.01.2020
404.01.2020
505.01.2020
606.01.2020KW 2
707.01.2020
808.01.2020
909.01.2020
1010.01.2020
1111.01.2020
1212.01.2020
1313.01.2020KW 3
1414.01.2020
1515.01.2020
1616.01.2020
1717.01.2020
1818.01.2020
1919.01.2020
2020.01.2020KW 4
2121.01.2020
2222.01.2020
2323.01.2020
2424.01.2020
2525.01.2020
2626.01.2020

ZelleFormatWert
B1"KW "Standard;;0

ZelleFormel
B1=(REST(A1;7)=2)*KALENDERWOCHE(A1;21)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste