Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Jeder Wert in Spalte in Funktion
#1
   
Moin zusammen, 
leider habe ich keinen passen Beitrag zu dem Thema gefunden. 
Ich würde gerne in der Spalte B alle Werte (einzelnd) mit einem Wert vergleichen. Dabei soll jeder Wert einzelnd mit dem jeweiligen Wert verglichen werden. 
Wie in meinem Screenshot zusehen. WENN die Spalte B einen Wert ausweist der größer ist als A2 (Wert 4) und kleiner ist als A3 (Wert 200) dann möchte ich ein X ausgespielt bekommen, ansonsten eine 0. 
Leider überprüft excel nicht jeden Wert in der Spalte sondern bildet eine Summe für die Spalte, daher ist der Wert immer 0. 
Optimale Lösung wäre, dass in Zeile C21 ein X herauskommen soll, da in Spalte B2 (Wert 2420) größer als A21 (Wert 2372) ist und kleiner als A22 (Wert 2469) ist. 
Ich benötige also für die Spalte B eine Iteration über jede einzelne Zeile in der Spalte.

Meine jetzige Formel ist:
=WENN(UND(B:B>A2;B:B

Vielen Dank für die Hilfe. Beste Grüße, Philipp
Antworten Top
#2
Hallöchen,

andersrum wird vielleicht ein Schuh draus.
A2 muss größer als das Minimum von B:B sein und kleiner als das Maximum ...
.      \\\|///      Hoffe, geholfen zu haben.
       ( ô ô )      Grüße, André aus G in T  
  ooO-(_)-Ooo    (Excel 97-2019+365)
Antworten Top
#3
Verwende

PHP-Code:
match(B2;A2:A40;1
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
[-] Folgende(r) 1 Nutzer sagt Danke an snb für diesen Beitrag:
  • Philipp2789
Antworten Top
#4
Danke für die schnelle Antwort, wenn ich es andersherum eintragen komme ich zum gleichen Ergebnis. Ich denke das er die Spalte B:B als Summe sieht und nicht jeden einzelnen Wert abfragt. 
Eigentlich sollte er jeden Wert aus der Spalte B mit A2 und A3 vergleichen, so meine Vorstellung. 
VG, Philipp
Antworten Top
#5
Hi,

kannst Du aussuchen, was Dir besser gefällt:

Code:
=WENN(ISTZAHL(AGGREGAT(15;6;B:B/(A2>B:B)/(A3<B:B);1));"x";0)
=WENN((A2:A1000>B2)*(A2:A1000<=B3);"x";0)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#6
Hi Edgar, danke für deine Hilfe. 
Leider greift die Formel nicht. 
Kannst du mir verraten wie ich durch die gesamte Spalte iterieren kann? 
In Zeile 21 müsste wenn alles passt ein X angezeigt werden. 
VG, Philipp     
Antworten Top
#7
Hi,

zeige mal statt der d... Bildchen die Datei mit Wunschergebnissen. Probiere aber vorher die andere Formel aus.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Nutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Philipp2789
Antworten Top
#8
Hallo Philipp,

da du auf snb's Vorschlag nicht eingegangen bist, habe ich ihn einmal konkretisiert:

=WENN(A3="";"";WENN(INDEX($B$2:$B$20;VERGLEICH(A3-1;$B$2:$B$20))>A2;"x";""))

ps.
a) Wenn ich dich richtig verstanden habe, willst du prüfen, ob zwischen zwei benachbarten Zellen der Spalte A ein Wert der Spalte B liegt.
b)Da beide Reihen steigend sind brauchst du die Vergleiche nicht iterieren, sondern must nur den größten Wert suchen der unter der Obergrenze liegt und prüfen, ob er über der Untergrenze liegt.


Angehängte Dateien
.xlsx   zwischen.xlsx (Größe: 9,15 KB / Downloads: 1)
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





[-] Folgende(r) 1 Nutzer sagt Danke an Ego für diesen Beitrag:
  • Philipp2789
Antworten Top
#9
Danke dir, die andere Formel führt zu keinem Ergebnis. 
Anbei die Datei. die IDs auf der rechten Seite kannst du ignorieren. 


.xlsx   Mappe1.xlsx (Größe: 53,28 KB / Downloads: 2)

Das wunschergebnis wäre, dass excel in der Spalte B alle Werte durchgeht und erkennt, das zum Beispiel der Wert B2 kleiner ist als A22 und größer als A21 und somit ein X setzt. 
Danke nochmal für eure Hilfe

Dank dir Helmut, das Ergebnis sieht schon sehr gut aus, probiere ich gleich mal an meiner Datei. 
VG, Philipp

Vielen Dank für eure Unterstützung liebe Community. 
Problem erfolgreich gelöst - Danke Helmut und Edgar. 

Viele Grüße, Philipp 


.xlsx   NEU.xlsx (Größe: 35,67 KB / Downloads: 3)
Antworten Top
#10
Hallo Philipp,

wenn du Edgars Vorschlag ein wenig anpasst und die Vergleichzeichen drehst, müssen die Werte in Spalte B nicht sortiert sein:

=WENN(ISTZAHL(AGGREGAT(15;6;B:B/(A2<B:B)/(A3>B:B);1));"x";0)

Die sortierte Version ist aber (besonders in großen Listen) weniger rechenaufwändig.


ps
Du hast beim Dank wieder den Ideengeber snb vergessen.  Blush
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





[-] Folgende(r) 1 Nutzer sagt Danke an Ego für diesen Beitrag:
  • Philipp2789
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste