Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Innerhalb eines Bereichs zählen, wie oft über eine bestimmte Dauer gemessen wird
#1
Hallo liebe Gemeinde,

für meine Projektarbeit habe ich Strommessungen an Durchlauferhitzern vorgenommen. Neben dem Energieverbrauch interessiert mich auch die Dauer der Benutzungen.
Für den Bereich von bescheidenen knapp 250.000 Messpunkten (ein Messpunkt entspricht etwa 2,79 sek.) möchte ich nun herausfinden, wie oft die Durchlauferhitzer wie lange benutzt wurden.
Ich möchte z.B. Aussagen treffen wie:
Die Durchlauferhitzer wurden
x mal < 5 sek;
x mal 6 - 10 sek;
...genutzt.
Meine Idee war nun, eine weitere Spalte zu erzeugen mit 1 =  Nutzung und 0, bzw Leer für keine Nutzung. In dem Bereich von B1 bis B250.000 müsste ich somit die Häufung der 1en zwischen den leeren Zellen zählen. Möglicherweise lässt sich auch eine Funktion direkt über die Zeit bilden, da weiß ich aber noch weniger wie ich es anstellen soll.
Nun komme ich nicht weiter und bitte euch um Hilfe.

Vielen Dank im Voraus!

Schöne Grüße

Löti

[url=Tabelle4

 ABCDEFG1Spalte1Spalte2Spalte3Spalte4Spalte5Spalte6Spalte72  Ampere    315.06.2020 111720 0 Zeilesek 415.06.2020 111723 0 12,7933893 515.06.2020 111726 0,01    615.06.2020 111729 0,01    715.06.2020 111732 0,01 nsekErgebnis815.06.2020 111734 0,01 12,79338931915.06.2020 111737 0,01 25,586778601015.06.2020 11174019,06 38,380167901115.06.2020 111743110,39 411,17355711215.06.2020 111746111,59    1315.06.2020 111748111,17    1415.06.2020 111751 0,04    1515.06.2020 111754 0,01    1615.06.2020 111757 0,01    1715.06.2020 111759 0,01    1815.06.2020 111802 0,01    1915.06.2020 111805 0,01    2015.06.2020 111808 0,01    2115.06.2020 111811 0,01    2215.06.2020 111813 0,01    2315.06.2020 111816 0,01    2415.06.2020 11181916,65    2515.06.2020 111822 0,23    26       
[/url]
Formeln der Tabelle
Zelle
Formel

B3
=WENN(C3>4;1;"")
B4
=WENN(C4>4;1;"")
E4
=1
B5
=WENN(C5>4;1;"")
B6
=WENN(C6>4;1;"")
B7
=WENN(C7>4;1;"")
B8
=WENN(C8>4;1;"")
E8
=1
F8
=E8*$F$4
G8
=1
B9
=WENN(C9>4;1;"")
E9
=2
F9
=E9*$F$4
B10
=WENN(C10>4;1;"")
E10
=3
F10
=E10*$F$4
B11
=WENN(C11>4;1;"")
E11
=4
F11
=E11*$F$4
G11
=1
B12
=WENN(C12>4;1;"")
B13
=WENN(C13>4;1;"")
B14
=WENN(C14>4;1;"")
B15
=WENN(C15>4;1;"")
B16
=WENN(C16>4;1;"")
B17
=WENN(C17>4;1;"")
B18
=WENN(C18>4;1;"")
B19
=WENN(C19>4;1;"")
B20
=WENN(C20>4;1;"")
B21
=WENN(C21>4;1;"")
B22
=WENN(C22>4;1;"")
B23
=WENN(C23>4;1;"")
B24
=WENN(C24>4;1;"")
B25
=WENN(C25>4;1;"")

[url=Tabelle4



Excel Tabellen im Web darstellen >>
[/url]Excel Jeanie HTML 4.8 ">Tabelle4

 
A
B
C
D
E
F
G

1
Spalte1
Spalte2
Spalte3
Spalte4
Spalte5
Spalte6
Spalte7
2
 
 
Ampere
 
 
 
 
3
15.06.2020 111720
 
0
 
Zeile
sek
 
4
15.06.2020 111723
 
0
 
1
2,7933893
 
5
15.06.2020 111726
 
0,01
 
 
 
 
6
15.06.2020 111729
 
0,01
 
 
 
 
7
15.06.2020 111732
 
0,01
 
n
sek
Ergebnis
8
15.06.2020 111734
 
0,01
 
1
2,7933893
1
9
15.06.2020 111737
 
0,01
 
2
5,5867786
0
10
15.06.2020 111740
1
9,06
 
3
8,3801679
0
11
15.06.2020 111743
1
10,39
 
4
11,173557
1
12
15.06.2020 111746
1
11,59
 
 
 
 
13
15.06.2020 111748
1
11,17
 
 
 
 
14
15.06.2020 111751
 
0,04
 
 
 
 
15
15.06.2020 111754
 
0,01
 
 
 
 
16
15.06.2020 111757
 
0,01
 
 
 
 
17
15.06.2020 111759
 
0,01
 
 
 
 
18
15.06.2020 111802
 
0,01
 
 
 
 
19
15.06.2020 111805
 
0,01
 
 
 
 
20
15.06.2020 111808
 
0,01
 
 
 
 
21
15.06.2020 111811
 
0,01
 
 
 
 
22
15.06.2020 111813
 
0,01
 
 
 
 
23
15.06.2020 111816
 
0,01
 
 
 
 
24
15.06.2020 111819
1
6,65
 
 
 
 
25
15.06.2020 111822
 
0,23
 
 
 
 
26
 
 
 
 
 
 
 


Formeln der Tabelle
Zelle
Formel

B3
=WENN(C3>4;1;"")
B4
=WENN(C4>4;1;"")
E4
=1
B5
=WENN(C5>4;1;"")
B6
=WENN(C6>4;1;"")
B7
=WENN(C7>4;1;"")
B8
=WENN(C8>4;1;"")
E8
=1
F8
=E8*$F$4
G8
=1
B9
=WENN(C9>4;1;"")
E9
=2
F9
=E9*$F$4
B10
=WENN(C10>4;1;"")
E10
=3
F10
=E10*$F$4
B11
=WENN(C11>4;1;"")
E11
=4
F11
=E11*$F$4
G11
=1
B12
=WENN(C12>4;1;"")
B13
=WENN(C13>4;1;"")
B14
=WENN(C14>4;1;"")
B15
=WENN(C15>4;1;"")
B16
=WENN(C16>4;1;"")
B17
=WENN(C17>4;1;"")
B18
=WENN(C18>4;1;"")
B19
=WENN(C19>4;1;"")
B20
=WENN(C20>4;1;"")
B21
=WENN(C21>4;1;"")
B22
=WENN(C22>4;1;"")
B23
=WENN(C23>4;1;"")
B24
=WENN(C24>4;1;"")
B25
=WENN(C25>4;1;"")



Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Antwortento top
#2
Hallöchen,

irgendwie hast Du eventuell beim Ändern was weggenommen, was die Jeanie zur richtigen Anzeige braucht ...
Daher mal nur ein Tipp. Schaue Dir mal SUMMENPRODUKT an.

Hier das Prinzip:
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
1149
225
336

ZelleFormel
D1=SUMMENPRODUKT((A1:A3<3)*B1:B3)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
Bei vielen auszuwertenden Klassen wird SUMMENPRODUKT etwas langsamer. Dann evtl. Pivot, ZÄHLENWENN oder HÄUFIGKEIT.
Antwortento top
#4
Bei diesem Datenvolumen wird auch ZÄHLENWENN() und andere ziemlich träge. Ich würde deshalb eine Lösung mit Power Query anstreben.

Unabhängig vom Lösungsansatz solltest du aber zuerst einmal eine ordentliche Mustermappe zur Verfügung stellen, in der auch händisch eingetragene Wusnschergebnisse enthalten sind.
VG, wisch
Wer Hilfe nimmt, sollte auch Hilfe geben! Auch wenn dies auf einem ganz anderem Gebiet geschieht.
Antwortento top
#5
Moin,

danke für eure Ratschläge und sorry für meine schlechte Darstellung. Ich hätte doch besser ins Bett gehen sollen.

Nun habe ich mein Problem wiefolgt gelöst:

Die Zeiten der Strommessungen summieren sich auf. Wenn kein Strom fließt wird eine leere Zelle erzeugt. Daraus resultiert #WERT!, was durch den Befehl WENNFEHLER zu 0 wird. Ohne diese Abfolge würde sich der letzte eingetragene Zeitwert bis zur nächsten Zapfung wiederholen. Um keine Zwischenwerte mit in die Betrachtung einzubinden, habe ich eine weitere Spalte für die finale Zapfdauer erstellt. Professionell ist sicherlich anders, aber es funktioniert.

Schöne Grüße

Löti

Tabelle4

ABCDEFGH
1
2Vorher
3
4ZeitNutzungStrom I in ASpalte1Spalte5Spalte6Spalte7
5
615.06.2020 11:17:200Zeilesek
715.06.2020 11:17:23012,7933893
815.06.2020 11:17:260,01
915.06.2020 11:17:290,01
1015.06.2020 11:17:320,01DLE Nutzung in sekErgebnis
1115.06.2020 11:17:340,01t<51
1215.06.2020 11:17:370,015<t<100
1315.06.2020 11:17:4019,0610>t>151
1415.06.2020 11:17:43110,39
1515.06.2020 11:17:46111,59
1615.06.2020 11:17:48111,17
1715.06.2020 11:17:510,04
1815.06.2020 11:17:540,01
1915.06.2020 11:17:570,01
2015.06.2020 11:17:590,01
2115.06.2020 11:18:020,01
2215.06.2020 11:18:050,01
2315.06.2020 11:18:080,01
2415.06.2020 11:18:110,01
2515.06.2020 11:18:130,01
2615.06.2020 11:18:160,01
2715.06.2020 11:18:1916,65
2815.06.2020 11:18:220,23
29
30
31Nachher
32
33ZeitNutzung t in sekMaxima/NutzungStrom I in ASpalte5Spalte6Spalte7Spalte8
34
3515.06.2020 11:17:20000Zeilesek
3615.06.2020 11:17:2300012,7933893
3715.06.2020 11:17:26000,01
3815.06.2020 11:17:29000,01
3915.06.2020 11:17:32000,01DLE Nutzung in sekErgebnis
4015.06.2020 11:17:34000,01t<51
4115.06.2020 11:17:37000,015<t<100
4215.06.2020 11:17:402,79338930409,0610>t>151
4315.06.2020 11:17:435,586778608010,39
4415.06.2020 11:17:468,380167913011,59
4515.06.2020 11:17:4811,1735572211,1735572211,17
4615.06.2020 11:17:51000,04
4715.06.2020 11:17:54000,01
4815.06.2020 11:17:57000,01
4915.06.2020 11:17:59000,01
5015.06.2020 11:18:02000,01
5115.06.2020 11:18:05000,01
5215.06.2020 11:18:08000,01
5315.06.2020 11:18:11000,01
5415.06.2020 11:18:13000,01
5515.06.2020 11:18:16000,01
5615.06.2020 11:18:192,7933893042,7933893046,65
5715.06.2020 11:18:22000,23
58
Formeln der Tabelle
ZelleFormel
B6=WENN(C6>4;1;"")
B7=WENN(C7>4;1;"")
E7=1
B8=WENN(C8>4;1;"")
B9=WENN(C9>4;1;"")
B10=WENN(C10>4;1;"")
B11=WENN(C11>4;1;"")
G11=1
B12=WENN(C12>4;1;"")
B13=WENN(C13>4;1;"")
G13=1
B14=WENN(C14>4;1;"")
B15=WENN(C15>4;1;"")
B16=WENN(C16>4;1;"")
B17=WENN(C17>4;1;"")
B18=WENN(C18>4;1;"")
B19=WENN(C19>4;1;"")
B20=WENN(C20>4;1;"")
B21=WENN(C21>4;1;"")
B22=WENN(C22>4;1;"")
B23=WENN(C23>4;1;"")
B24=WENN(C24>4;1;"")
B25=WENN(C25>4;1;"")
B26=WENN(C26>4;1;"")
B27=WENN(C27>4;1;"")
B28=WENN(C28>4;1;"")
B35=WENNFEHLER((WENN(D35<4;"";$G$36)+B34);0)
C35=WENN(B36>0;0;B35)
B36=WENNFEHLER((WENN(D36<4;"";$G$36)+B35);0)
C36=WENN(B37>0;0;B36)
F36=1
B37=WENNFEHLER((WENN(D37<4;"";$G$36)+B36);0)
C37=WENN(B38>0;0;B37)
B38=WENNFEHLER((WENN(D38<4;"";$G$36)+B37);0)
C38=WENN(B39>0;0;B38)
B39=WENNFEHLER((WENN(D39<4;"";$G$36)+B38);0)
C39=WENN(B40>0;0;B39)
B40=WENNFEHLER((WENN(D40<4;"";$G$36)+B39);0)
C40=WENN(B41>0;0;B40)
H40=ZÄHLENWENNS(C35:C57;"<" & 5;C35:C57;">" & 1)
B41=WENNFEHLER((WENN(D41<4;"";$G$36)+B40);0)
C41=WENN(B42>0;0;B41)
H41=ZÄHLENWENNS(C35:C57;"<" & 10;C35:C57;">" & 5)
B42=WENNFEHLER((WENN(D42<4;"";$G$36)+B41);0)
C42=WENN(B43>0;0;B42)
H42=ZÄHLENWENNS(C35:C57;"<" & 15;C35:C57;">" & 10)
B43=WENNFEHLER((WENN(D43<4;"";$G$36)+B42);0)
C43=WENN(B44>0;0;B43)
B44=WENNFEHLER((WENN(D44<4;"";$G$36)+B43);0)
C44=WENN(B45>0;0;B44)
B45=WENNFEHLER((WENN(D45<4;"";$G$36)+B44);0)
C45=WENN(B46>0;0;B45)
B46=WENNFEHLER((WENN(D46<4;"";$G$36)+B45);0)
C46=WENN(B47>0;0;B46)
B47=WENNFEHLER((WENN(D47<4;"";$G$36)+B46);0)
C47=WENN(B48>0;0;B47)
B48=WENNFEHLER((WENN(D48<4;"";$G$36)+B47);0)
C48=WENN(B49>0;0;B48)
B49=WENNFEHLER((WENN(D49<4;"";$G$36)+B48);0)
C49=WENN(B50>0;0;B49)
B50=WENNFEHLER((WENN(D50<4;"";$G$36)+B49);0)
C50=WENN(B51>0;0;B50)
B51=WENNFEHLER((WENN(D51<4;"";$G$36)+B50);0)
C51=WENN(B52>0;0;B51)
B52=WENNFEHLER((WENN(D52<4;"";$G$36)+B51);0)
C52=WENN(B53>0;0;B52)
B53=WENNFEHLER((WENN(D53<4;"";$G$36)+B52);0)
C53=WENN(B54>0;0;B53)
B54=WENNFEHLER((WENN(D54<4;"";$G$36)+B53);0)
C54=WENN(B55>0;0;B54)
B55=WENNFEHLER((WENN(D55<4;"";$G$36)+B54);0)
C55=WENN(B56>0;0;B55)
B56=WENNFEHLER((WENN(D56<4;"";$G$36)+B55);0)
C56=WENN(B57>0;0;B56)
B57=WENNFEHLER((WENN(D57<4;"";$G$36)+B56);0)
C57=WENN(B58>0;0;B57)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste