Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Index und Vergleich
#1
Hallo Zusammen

Ich versuche gerade eine Excelformel zu schreiben. Aber es klappt noch nicht so richtig. Folgendesitutation:

In der Spalte F in der Zeile 174 ist der Mitarbeiter Bernd. Der Bernd wird mehrfach in Spalte F von der Zeile 1-166 mehrfach ausgelistet. In der Spalte A von der Zeile 1-166 sind verschiedene Aufgabenbereich aufgelistet. Nun wollte ich alle Aufgaben, welche Bernd hat, in der Spalte G Zeile 175 darstellen. Ich habe diese Formel geschrieben. Es wir mir aber aktuell nur einen Aufgabenbereich Angezeigt. Nun weiss ich nicht mehr weiter. Hat für mich jemanden einen Tipp?

=INDEX(A1:A166;VERGLEICH(F174;F1:F166;0))


Vielen Dank und LG

djdlife
Antwortento top
#2
Hallo djdlife,

ich würde nicht alle Aufgaben eines Mitarbeiter in eine Zelle schreiben.

Mit:
Code:
=WENNFEHLER(INDEX($A$1:$A$166;AGGREGAT(15;6;ZEILE($F$1:$F$166)/(($F$1:$F$166)=$F$174);ZEILE(A1)));"")

kann man alle Aufgaben des Mitarbeiters untereinander schreiben.
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





[-] Folgende(r) 1 Benutzer sagt Danke an Ego für diesen Beitrag:
  • djdlife
Antwortento top
#3
ok, vielen dank. Aber mich würde trotzdem noch Interessieren wieso, dass mir nur einen Wert angezeigt wird bei meiner Formel.
Antwortento top
#4
Hi,

VERGLEICH() sucht nicht mehr weiter, sobald ein Treffer erzielt wurde. Es wird die erste Zeilennummer, in der sich der Treffer befindet, an INDEX() übergeben. Und das war's.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.zitate.net
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • djdlife
Antwortento top
#5
ok, was wäre dann der richtige Ansatz?
Antwortento top
#6
Hi,

für was? Ist Helmuts Vorschlag nicht relevant für dich?
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.zitate.net
Antwortento top
#7
doch, aber ich möchte gerne mir einbisschen Excel wissen aneigen.

Aber eine Frage hätte ich noch zu Helmuts Vorschlag. Sehe ich, dass richtig bei der Formel:

=WENNFEHLER(INDEX($A$1:$A$166;AGGREGAT(15;6;ZEILE($F$1:$F$166)/(($F$1:$F$166)=$F$174);ZEILE(A1)));"")

Das ich zuerst wissen muss, wie viel Aufgaben das Bernd hat? und dann in jeder Zeile folgendes Eingeben muss:

=WENNFEHLER(INDEX($A$1:$A$166;AGGREGAT(15;6;ZEILE($F$1:$F$166)/(($F$1:$F$166)=$F$174);ZEILE(A1)));"")
=WENNFEHLER(INDEX($A$1:$A$166;AGGREGAT(15;6;ZEILE($F$1:$F$166)/(($F$1:$F$166)=$F$174);ZEILE(A2)));"")
=WENNFEHLER(INDEX($A$1:$A$166;AGGREGAT(15;6;ZEILE($F$1:$F$166)/(($F$1:$F$166)=$F$174);ZEILE(A3)));"")
=WENNFEHLER(INDEX($A$1:$A$166;AGGREGAT(15;6;ZEILE($F$1:$F$166)/(($F$1:$F$166)=$F$174);ZEILE(A4)));"")
etc...
Antwortento top
#8
Nicht ganz.

Die Formel gibst du nur einmal ein und ziehst sie nach Bedarf einfach runter.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.zitate.net
Antwortento top
#9
Hallo djdlife,

alle Aufgaben des Mitarbeiters in eine Zelle ginge zB so:


Code:
{
=TEXTVERKETTEN("; ";WAHR;WENN((F1:F166)=F175;A1:A166;""))
}
Achtung! Matrixformel! Die geschweiften Klammern werden nicht mit eingegeben, sondern jede Bearbeitung  der Formel  wird mit Strg+Shift+Enter abgeschlossen.
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top
#10
Moin, ich denke, man kann ohne (CSE-)Formeln auskommen. Aber ich denke mir keine Beispiele aus. Mit einer Beispieldatei könnte man mal schauen, was da mit Power Query machbar ist...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste