Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Index mit 2 Suchkriterien und mehreren Ergebnissen
#1
Lightbulb 
Hallo zusammen,

ich komme an einem Excel-Problem nicht alleine weiter und hoffe, dass mir jemand helfen kann.

Ich habe eine Tabelle, in der Produktname, Größe, Farbe und Preis dargestellt sind. Nun wollte ich wissen, welche Produkte eine gewisse Farbe haben und was diese kosten. Dabei war mir wichtig, dass nicht wie beim klassischen SVERWEIS nur das erste Produkt mit der entsprechenden Farbe angezeigt wird sondern alle Produkte. In Bild 1 und 2 habe ich dargestellt wie ich bisher vorgegangen bin, das funktioniert super. 

Nun will ich aber nicht nur ein Suchkriterium (hier: welche Produkte sind blau und was kosten diese), sonder nach 2 Kriterien filtern. Z.B. welche Produkte sind blau und haben die Größe Mittel. Wichtig ist mir wieder, dass dabei alle Produkte angezeigt werden, die diese Kriterien erfüllen (in meinem Beispiel Produkt 11 und Produkt 14).

Schonmal vielen Dank für eure Hilfe im Voraus!


Angehängte Dateien Thumbnail(s)
       

.xlsx   Excel.xlsx (Größe: 16,81 KB / Downloads: 2)
Antwortento top
#2
Hola,

lade bitte eine Exceldatei hoch. Bilder baut niemand nach.

Gruß,
steve1da
Antwortento top
#3
Lightbulb 
Hallo zusammen,

ich komme an einem Excel-Problem nicht alleine weiter und hoffe, dass mir jemand helfen kann.

Ich habe eine Tabelle, in der Produktname, Größe, Farbe und Preis dargestellt sind. Nun wollte ich wissen, welche Produkte eine gewisse Farbe haben und was diese kosten. Dabei war mir wichtig, dass nicht wie beim klassischen SVERWEIS nur das erste Produkt mit der entsprechenden Farbe angezeigt wird sondern alle Produkte. In Bild 1 und 2 habe ich dargestellt wie ich bisher vorgegangen bin, das funktioniert super. 

Nun will ich aber nicht nur ein Suchkriterium (hier: welche Produkte sind blau und was kosten diese), sonder nach 2 Kriterien filtern. Z.B. welche Produkte sind blau und haben die Größe Mittel. Wichtig ist mir wieder, dass dabei alle Produkte angezeigt werden, die diese Kriterien erfüllen (in meinem Beispiel Produkt 11 und Produkt 14).

Schonmal vielen Dank für eure Hilfe im Voraus!


Angehängte Dateien
.xlsx   Excel.xlsx (Größe: 16,81 KB / Downloads: 7)
Antwortento top
#4
Hi Joe,

zukünftig bitte anstelle von Bildchen eine Beispieldatei posten.

Hier mein Vorschlag:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFG
1ProdFarbeGrößePreisFarbeblau
2Prod1blau202Größe20
3Prod2blau224
4Prod3blau206ProdPreis
5Prod4grün228Prod12
6Prod5grün2410Prod36
7Prod6grün2612
8Prod7rot2414
9Prod8rot2616
10Prod9rot2818
11Prod10rot3020

ZelleFormel
F5=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($B$1:$B$20)/($B$1:$B$20=$G$1)/($C$1:$C$20=$G$2);ZEILE(A1)));"")
G5=WENNFEHLER(SVERWEIS(F5;$A$1:$D$20;4;0);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 2 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • thrustssc, joe_doe
Antwortento top
#5
Vielen Dank für den Hinweis, ich habe die Excel Datei nun mittlerweile hochgeladen. 

Zu deinem Vorschlag: Die Funktion Aggregat kann ich nicht nutzen, da ich die Tabelle tatsächlich in Google Sheets (Firma arbeitet mit Google nicht mit Excel) machen muss. Aggregat gibt es in Google Sheets leider nicht. Gibt es noch eine andere Möglichkeit?

Liebe Grüße
Antwortento top
#6
Dann solltest du das auch in deinem Profil vermerken! Ich habe keine Lust, für den Papierkorb zu arbeiten.

Btw, ich habe deine beiden Themen zusammengefügt; du kannst innerhalb der ersten 60 Minuten nach Posten eines Beitrags diesen editieren - ein zweites Thema ist nicht nötig.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#7
Hallo,
in Google Sheets kannst du die FILTER Funktion benutzen.

https://support.google.com/docs/answer/3093197?hl=de

=Filter(C2:D17;A2:A17=G1;B2:B17=G2)
Cadmus
Antwortento top
#8
Hi,

dann kann ich dir noch diese Lösung mit zwei Hilfsspalten (kannst du einfach ausblenden) anbieten:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHI
1ProdFarbeGrößePreisHS1HS2Farberot
2Prod1blau2029Größe26
3Prod2blau22411
4Prod3blau206ProdPreis
5Prod4grün228Prod816
6Prod5grün2410Prod1020
7Prod6grün2612
8Prod7rot2414
9Prod8rot26169
10Prod9rot2418
11Prod10rot262011

ZelleFormel
E2=WENN(UND(WENN(B2=$I$1;B2;"")&WENN(C2=$I$2;C2;"")=$I$1&$I$2);ZEILE();"")
F2=WENNFEHLER(KKLEINSTE($E$2:$E$20;ZEILE(A1));"")
H5=WENNFEHLER(INDEX(A:A;KKLEINSTE(F2;1));"")
I5=WENNFEHLER(SVERWEIS(H5;$A$1:$D$20;4;0);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • joe_doe
Antwortento top
#9
(10.07.2020, 20:54)WillWissen schrieb: Hi Joe,

zukünftig bitte anstelle von Bildchen eine Beispieldatei posten.

Hier mein Vorschlag:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFG
1ProdFarbeGrößePreisFarbeblau
2Prod1blau202Größe20
3Prod2blau224
4Prod3blau206ProdPreis
5Prod4grün228Prod12
6Prod5grün2410Prod36
7Prod6grün2612
8Prod7rot2414
9Prod8rot2616
10Prod9rot2818
11Prod10rot3020

ZelleFormel
F5=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($B$1:$B$20)/($B$1:$B$20=$G$1)/($C$1:$C$20=$G$2);ZEILE(A1)));"")
G5=WENNFEHLER(SVERWEIS(F5;$A$1:$D$20;4;0);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Klasse hab ich mir mal gespeichert was alles so möglich ist unglaublich ...
Antwortento top
#10
So funktioniert es, vielen Dank!!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste