Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Index - Schwankung 3%
#1
Hallo,
komme leider nicht mehr weiter - vielleicht kann jemand mir bitte weiterhelfen.
In der Anlage die Datei.
Es geht um eine Indexberechnung - Schwankung z.B. 3%
Nach Erreichung der 3% muss ich um eine korrekte Berechnung in der Spalte "D" die Formel berichtigen.
z.B. 
D6 =WENN(((C6/$C$4)-100%)<=3%;"";(C6/$C$4)-100%)
D10 =WENN(((C10/$C$6)-100%)<3%;"";(C10/$C$6)-100%)

von c4 auf c6 umstellen!

Wie kann ich das bewerkstelligen, damit das von selber - eventuell mit einer Formel bzw. Makro - umstellt und richtig rechnet?

Lg Ubi5


Angehängte Dateien
.xlsm   Schwellenwert 3%.xlsm (Größe: 12,04 KB / Downloads: 4)
Antworten Top
#2
Hi,

z.B. so, in D5 und nach unten ziehen:

Code:
=WENN((C5/INDEX(C:C;WENNFEHLER(VERWEIS(9;1/($D$4:D4<>"");ZEILE($D$4:D4));4))-100%)<=3%;"";C5/INDEX(C:C;WENNFEHLER(VERWEIS(9;1/($D$4:D4<>"");ZEILE($D$4:D4));4))-100%)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#3
Funktioniert super - Danke!
Ware es auch möglich, dass die Werte in der Spalte "E" auch automatisch eingetragen werden?

Lg Ubi5
Antworten Top
#4
Hi,

so, in E4:

Code:
=WENN(B4="";SUMME(E3:INDEX(E:E;ZEILE()-12));RUNDEN(SUMME($D$4:D4;1)*100;2))
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#5
Hallo Edgar - nochmals Danke!

Habe die letzte Anweisung eingetragen - rechnet aber leider nicht ganz genau - siehe Datei!

Lg Ubi5


Angehängte Dateien
.xlsm   Schwellenwert 3%.xlsm (Größe: 13,34 KB / Downloads: 3)
Antworten Top
#6
Hi,
in E4:

Code:
=WENN(B4="";SUMME(E3:INDEX(E:E;ZEILE()-12));RUNDEN(MAX(100;MAX(WENN($B$3:B3<>"";$E$3:E3))*SUMME(1;D4));2))
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#7
Hallo Edgar,

recht herzlichen Dank für deine Bemühungen. 
Da die berechneten neuen Indexwerte nicht 100% mit den ermittelten Werten der Statistik Austria übereinstimmen - siehe Datei -
nehme ich an, dass diese Problem in der Spalte "D" Schwankung 3% liegt und dieses nicht berichtigt werden kann.
Daher habe ich in der Spalte "F" die Schwankungen in eine Dezimalzahl umgewandelt.

Nochmals Danke!

Lg Ubi5


Angehängte Dateien
.xlsm   Schwellenwert 3%.xlsm (Größe: 14,06 KB / Downloads: 1)
Antworten Top
#8
Hi,

bist Du sicher, dass Deine Zahlen stimmen?
Wo kommen die her?
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#9
Hallo Edgar,
die Zahlen stimmen - 

habe "runden;3" sehe unten eingefügt - dann stimmt das Ergebnis - Zufall?????


=WENN((C6/INDEX(C:C;WENNFEHLER(VERWEIS(9;1/($D$4:D5<>"");ZEILE($D$4:D5));4))-100%)<=3%;"";RUNDEN(C6/INDEX(C:C;WENNFEHLER(VERWEIS(9;1/($D$4:D5<>"");ZEILE($D$4:D5));4))-100%;3))

Lg Ubi5
Antworten Top
#10
Hi,

glaube ich alles nicht!
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste