Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

IP Adressen generieren
#1
Hallo Miteinander,

ich suche mal wieder nach einer Lösung für ein zumindest mich exotisches Problem, das ich zwar händisch lösen könnte, aber da sitze ich bis Weihnachten dran. Vielleicht gibts ja eine Lösung wie man das zumindest halbwegs automatisiert lösen könnte. Dazu folgendes:

Ich habe eine Tabelle mit IP Adressen, die je Zeile den Beginn und das Ende einer IP Klasse beinhaltet:

Anfang Ende Summe
2.16.6.0 2.16.7.255 512

Was ich aber brauche, ist jede IP Adresse einzeln, also:

2.16.6.0
2.16.6.1
2.16.6.2
2.16.6.3
2.16.6.4
....
2.16.7.255

Sieht da jemand einen Weg, wie man das lösen könnte?
Antwortento top
#2
Hallo,

mit VBA alle Werte in Spalte A schreiben, könnte so gehen:

Code:
columns(1).numberformat = "@"
for b3 = 6 to 7
    for b4 = 0 to 255
        r=r+1
        cells(r, 1) = "2.16." & b3 & "." & b4
    next b4
next b3

(ungeprüft)

Es wäre aber sicher besser das "on the fly", also zusammen mit dem Befehl zu generieren.

mfgf
Antwortento top
#3
Ich hab das Problem zwischenzeitlich anders gelöst, ohne Excel. Ich hab nur mal wieder zu kompliziert gedacht und hab erst nach Stunden festgestellt, dass es dafür freie Software gibt, die sogar gleich noch mehr macht.

Trotzdem Danke!
Antwortento top
#4
Hallöchen,

mal noch für die, die doch Excel nehmen wollen Smile

Wenn man oben die erste IP eingibt, kann man die nach unten ziehen bis Zeile 256 oder darüber - geht natürlich auch mit mehreren Spalten zugleich. Am Ende löscht man die Zeilen ab 257.

Man könnte auch eine Formellösung nehmen, hier mal ein Ansatz:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
12.16.6.02.11.7.0Bereich2.16.6
22.16.6.12.11.7.1Start0
32.16.6.22.11.7.2Ende3
42.16.6.32.11.7.32.16.6.0
52.16.6.42.11.7.42.16.6.1
62.16.6.52.11.7.52.16.6.2
72.16.6.62.11.7.62.16.6.3
82.16.6.72.11.7.7
92.16.6.82.11.7.8
102.16.6.92.11.7.9

ZelleFormel
D4=WENN(ZEILE(A1)-1<=$D$3;$D$1 & "." & $D$2 + ZEILE(A1)-1;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg

Das Makro ließe sich auch ausbauen, dass man die Daten z.B. eingibt statt einzutragen, die Spalte nimmt wo der Cursor gerade steht, usw. - je nach eigenem Gusto ...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste