Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Hilfe bei Formel mit SVERWEIS und Datumsberechnung
#1
Hallo liebe Excel-Experten,
ich brauch mal wieder Eure Hilfe.

In meiner Rechnungsliste (siehe Anhang) möchte ich in den Spalten D und E mit der SVERWEIS-Funktion auf Daten des zweiten Tabellenblattes (Tabelle2) verweisen, was für mich kein Problem wäre.
Ich möchte aber, dass gleichzeitig eine Datumsberechnung erfolgt, also Rechnungsdatum + die entsprechenden Tage aus der Tabelle2 beim jeweiligen Lieferanten.

In Zelle D2 soll dann also der 13.07.2020 stehen, in Zelle E2 der 20.08.2020 usw...

Hier stoße ich leider an meine Grenzen.

Ich danke Euch für Eure Hilfe.
Urmel


Angehängte Dateien
.xlsx   Rechnungsliste.xlsx (Größe: 10,53 KB / Downloads: 4)
Antwortento top
#2
Hola,

wenn der Sverweis kein Problem ist, was ist es dann?
Und warum soll in E2 der 20.08.2020 erscheinen? Das wären mehr als 30 Tage.

Gruß,
steve1da
Antwortento top
#3
Hi Urmel,

so:
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
1RechnungsdatumLieferantRechnungsbetragZahldatum mit SkontoZahldatum ohne Skonto
213.07.2020Müller KG200,50 €13.07.202012.08.2020
314.07.2020Meier GmbH1.355,30 €21.07.202028.07.2020
415.07.2020Schmidt OHG799,99 €25.07.202014.08.2020
516.07.2020Schneider AG1.650,00 €16.07.202026.07.2020

ZelleFormel
D2=$A2+SVERWEIS($B2;Tabelle2!$A$1:$C$52;SPALTE(B$1);0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Deine Tagesangaben stimmen nicht.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#4
Oh ja sorry steve1da. Hab mich verschrieben. Ich meinte natürlich den 12.08.2020


Hi WillWissen,



funktioniert perfekt. Ich danke Dir !!!!!!



noch eine abschließende Frage:

Wie müsste die Formel aussehen, damit die Spalte D2 leer bleibt, wenn in der SVERWEIS-Tabelle in Spalte B der Wert 0 steht?
Ich könnte auch mit einer 0 statt einer leeren Zelle leben.

Dankeschön.


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#5
Hi Urmel,

Code:
=WENN($A2+SVERWEIS($B2;Tabelle2!$A$1:$C$52;SPALTE(B$1);0)=A2;"";$A2+SVERWEIS($B2;Tabelle2!$A$1:$C$52;SPALTE(B$1);0))
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
Sensationell! Tausend Dank
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste