Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Größer/gleich mit Sverweis?
#1
Hallo zusammen!

Ich habe folgendes Problem:
Sverweis nimmt, wenn keine genaue Übereinstimmung vorliegt, immer den nächstkleineren Wert, ich brauche aber den nächstgrößeren Wert.
Folgende Daten:

In Zelle E31 soll der nächstgrößere Wert verglichen mit Zelle E26 erscheinen.
Die Liste der möglichen Werte ist in "Dropdown" A13:A19 hinterlegt.

Steht also in E26 "5,6" soll sich die Tabelle aus dem Dropdown-Bereich den Wert "6" ziehen. Es zieht aber aktuell "4,5"...

Ich hoffe, ich habe mich verständlich ausgedrückt... Hilfe? Huh
Antwortento top
#2
Moin Isi,

da du keine Beispieldaten zeigst, nehme ich mal meine eigenen. Wink

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
14,550110
2220
3330
4440
5550

ZelleFormel
B1=SVERWEIS(AUFRUNDEN(A1;0);$D$1:$E$5;2;1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Moin!
EDIT:
@Günter:
Der TE hat nicht ausschließlich Ganzzahlen in seinem Dropdown!

Für Deine Version nutze eine Kombi aus INDEX und VERGLEICH
Aktuelle Excel-Versionen erschlagen so etwas mit dem neuen XVERWEIS

ABCDE
14,55,55,5
25,66,66,6
131,1
142,2
153,3
164,4
175,5
186,6
197,7
20

ZelleFormel
D1=XVERWEIS(C1;A$13:A$19;A$13:A$19;;1)
E1=INDEX(A$13:A$19;VERGLEICH(C1;A$13:A$19)+1)

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#4
Was ist denn ein TE?

Die Werte, die in E31 stehen sollen (in Dropdown A13:A19 hinterlegt) sind:
4,5
6
7,5
9
10,5
12
13,5

Die Werte, die in E26 stehen, können alles von 0,1-13,5 sein, mit 1 Dezimalstelle.

Sorry, hatte ich nicht mit rein geschrieben.
Für den XVerweis stelle ich mich entweder zu doof an, oder er geht dann nicht bei meiner Zahlen-Variante oben. Undecided

Bei der Variante "Aufrunden" steht "#Name?" in der Zelle :D
Antwortento top
#5
Hi Isi,

sortiere deine Vergleichswerte absteigend, dann erzielst du dein Ergebnis mit INDEX/VERGLEICH():
Arbeitsblatt mit dem Namen 'Tabelle1'
AE
1313,5
1412
1510,5
169
177,5
186
194,5
25
266,1
27
28
29
30
317,5

ZelleFormel
E31=INDEX($A$13:$A$19;VERGLEICH($E$26;$A$13:$A$19;-1))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Die RUNDEN-Fkt. geht hier nicht (hatte ja keine Vergleichszahlen), ob der XVERWEIS() bei dir funktionieren würde, kann ich nicht beurteilen. Ich weiß nicht, was 10 für eine Excelversion ist.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
(11.06.2020, 09:05)Isi schrieb: Was ist denn ein TE?
https://de.wikipedia.org/wiki/TE
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#7
Super, vielen lieben Dank Günter!
Idea
Antwortento top
#8
(11.06.2020, 10:15)WillWissen schrieb: sortiere deine Vergleichswerte absteigend, dann erzielst du dein Ergebnis mit INDEX/VERGLEICH()

Das ist doch gar nicht notwendig (wie man an meinem obigen Beispiel sieht).
Schließlich reicht es, in der INDEX-Formel den durch VERGLEICH ermittelten Zeilenwert um 1 zu erhöhen.
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#9
Hi Ralf,

wenn generell der nächsthöhere Wert ausgegeben werden soll, dann passt natürlich dein Vorschlag. Es kommt zwar beim TE überhaupt nicht zur Sprache, was bei einem Treffer passieren soll; ich gehe mal einfach davon aus, dass dann auch der Treffer angezeigt werden soll. Dann wäre mein Vorschlag der zielführendere.

Mein Vorschlag - Ergebnis genauer Treffer:
Arbeitsblatt mit dem Namen 'Tabelle1'
AE
1313,5
1412
1510,5
169
177,5
186
194,5
25
2610,5
27
28
29
30
3110,5

ZelleFormel
E31=INDEX($A$13:$A$19;VERGLEICH($E$26;$A$13:$A$19;-1))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Dein Vorschlag - Ergebnis Treffer:
Arbeitsblatt mit dem Namen 'Tabelle1'
AE
134,5
146
157,5
169
1710,5
1812
1913,5
25
2610,5
27
28
29
30
3112

ZelleFormel
E31=INDEX(A$13:A$19;VERGLEICH(E26;A$13:A$19)+1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#10
Da hast Du natürlich Recht!
(hab an das nächstliegende nicht gedacht)
Blush

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste