Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Das Update ist abgeschlossen, Ihr könnt unser Forum jetzt wieder wie gewohnt nutzen. Eventuelle Bugs und Auffälligkeiten postet Ihr bitte im entsprechenden Forum im Bereich Forumstechnik. x


Gleiche Werte addieren
#1
Hallo,

ich möchte gerne automatisch (Makro/Funktion oder ähnliches) den gesamten Brutto- bzw Nettowert ausgerechnet haben. Dh er soll bei gleicher Rechnungsnummer die einzelnen Kategorien addieren. Am liebsten mit den verbundenen Zellen. Falls das jedoch nicht geht, da verbundene Zellen nicht so gut zu händeln sind, könnte ich auch die Spalten Rechnungsnummer und die Brutto- und Nettosummen wieder auftrennen. Dann weiß ich trotzdem nicht wie ich das bewerkstelligen kann.

Vielen Dank für eure Hilfe,
Tommy


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 9,8 KB / Downloads: 9)
Antworten Top
#2
Hallo,

leider arbeitest du mit Verbundenen Zellen. Da diese fast alle Excelfunktionen beeinträchtigen, wird es da keine Lösung für dein Problem geben.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antworten Top
#3
Hi,

auch ich rate dir, auf verbundene Zellen generell zu verzichten. Schreibe in jede Zeile alle Werte. Nur dann kannst du sauber arbeiten.

Wenn du es optisch etwas "schöner" haben willst, dann mach in die entsprechenden Spalten (A2:A7, B2:B7, H2:H7, I2:I7) die bed.Form. mit der Formel =$B2=$B1 und dem Format ;;; Das bewirkt, dass nur der erste Eintrag sichtbar ist.
Summenformeln:
H2: =SUMMEWENNS($C$2:$C$7;$B$2:$B$7;B2)
I2: =SUMMEWENNS($D$2:$D$7;$B$2:$B$7;B2)


Falls du dennoch an den verbunden Zellen festhalten willst, solltest du eine Hilfsspalte (die man ausblenden kann) einfügen.
L2: =WENN(B2="";L1;B2)
J2: =SUMMEWENNS($C$2:$C$7;$L$2:$L$7;L2)
K2: =SUMMEWENNS($D$2:$D$7;$L$2:$L$7;L2)

Eine Darstellung als verbundene Zelle wird damit aber nicht möglich sein. Allerdings musst du das bei den anderen Zallen ja auch händisch machen...
Gruß,
Helmut

Win10 - Office365 / MacOS - Office365
[-] Folgende(r) 1 Nutzer sagt Danke an HKindler für diesen Beitrag:
  • magixxx619
Antworten Top
#4
Hallo an alle

ich gebe zu das verbundene Zellen immer kniffelig sind.  Es reizte mich aber nach einer Makro Lösung zu suchen.
Nach etwas Überlegen war das simpler als ich dachte.  Das schöne an Excel ist, mit Makros kann man viel tricksen!

mfg Gast 123
.xls   Test.xls (Größe: 17,5 KB / Downloads: 3)
Antworten Top
#5
Hallo Gast 123,

Zitat:Das schöne an Excel ist, mit Makros kann man viel tricksen!

die Phase des "Tricksens mit VBA" habe ich schon vor Jahren hinter mir gelassen! Es ist sicher nicht der Sinn von Makros, sie dafür zu missbrauchen, dass man versucht, Dinge zu realisieren, die Excel eigentlich nicht hergibt. Es gibt genug wunderbare Funktionen, mit denen man sehr viel erreichen kann, wenn man ein paar Grundregeln für den Listenaufbau beachtet. 
Bei den Bastellösungen mit VBA besteht ja immer die Gefahr, dass bei Änderungen in bzw. an der Liste nichts mehr funktioniert. Wenn dann der VBA-Bastler nicht mehr greifbar ist, ist alles K...e!
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
[-] Folgende(r) 2 Nutzer sagen Danke an Klaus-Dieter für diesen Beitrag:
  • shift-del, RPP63
Antworten Top
#6
Hallo Klaus Dieter

du hast Recht, das man die Dinge optimieren soll. die Technik geht ja immer weiter.
Mir macht es halt Spass auch bei verzwickten Datenstrukturen eine Lösung zu finden.

Es ist ein zweischneidigedes Schwert.  Viele Menschen halten gerne an gewohnten Dateien fest.
Kaufmännisch denkene und orientierte Leute werden aber immer für die neue Technik offen sein.

mfg Gast 1234
Antworten Top
#7
Hast du eine Lösung gefunden gehabt? In der Datei sehe ich nichts weiter oder übersehe ich etwas? Danke

Vielen Dank für deine Lösung - funktioniert einwandfrei.
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste