Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Geburtstage zählen
#1
Hallo!

Ich habe folgendes Problem: Es sollen die verschiedenen Geburtstage von einer Reihe von Leuten gezählt werden. Es soll so gezählt werden, damit man weiß, wieviele Leute haben im Jahr Geburtstag. 

Wenn z. B. zwei Leute an ein und demselben Tag, aber in verschiedenen Jahren, Geburtstag haben, soll die Zahl 2 in der entsprechenden Zelle auftauchen (siehe Beispieldatei), selbst wenn diese Leute mehrfach in der Liste auftauchen.

Meine Frage also: Wie muß die Formel in Zelle F3 meiner Beispieldatei aussehen? Ich beiß mir gerade daran die Zähne aus... 05

Vielen Dank schon mal im voraus...


Angehängte Dateien
.xlsm   Frage.xlsm (Größe: 8,96 KB / Downloads: 2)
Antwortento top
#2
Hallo Al,

z.B. mit folgender Formel:

PHP-Code:
=SUMMENPRODUKT(N(VERGLEICH(B3:B99&C3:C99&D3:D99;B3:B99&C3:C99&D3:D99;0)=ZEILE(B3:B99)-2)*(D3:D99>0)) 
Gruß Werner
.. , - ...
[-] Folgende(r) 1 Benutzer sagt Danke an neopa für diesen Beitrag:
  • Al Swearengen
Antwortento top
#3
Danke für die schnelle Antwort, neopa!

Sie ist super und funktioniert auch toll.

Leider habe ich mich falsch ausgedrückt und auch die Frage falsch formuliert. Entschuldigung dafür.. Blush

Ich habe die Datei überarbeitet und nochmal wieder angehängt, diesesmal aber richtig.


Also, gefragt wird nach der Formel im Blatt 2 in Zelle C3, C4 usw.

Irgendeine Idee dafür?


Angehängte Dateien
.xlsm   Frage.xlsm (Größe: 65,78 KB / Downloads: 5)
Antwortento top
#4
Hallo Al,

... dann In C2:
PHP-Code:
=SUMMENPRODUKT(N(VERGLEICH(Tabelle1!$B$3:$B$99&Tabelle1!$C$3:$C$99&Tabelle1!$D$3:$D$99;
Tabelle1!$B$3:$B$99&Tabelle1!$C$3:$C$99&Tabelle1!$D$3:$D$99;0)=ZEILE(C$3:C$99)-2)
*(
TEXT(Tabelle1!$D$3:$D$99;"T.MMMM")=B3&"."&B$2)) 

ziehend nach unten und in die anderen Monatsspalten kopieren.

Ich würde die Formel so im Namensmanager definieren und dessen von Dir festgelegten Formelnamen im Tabellenblatt einsetzen.
Gruß Werner
.. , - ...
[-] Folgende(r) 1 Benutzer sagt Danke an neopa für diesen Beitrag:
  • Al Swearengen
Antwortento top
#5
Super! Wahnsinn! Läuft!

Kannst du mir trotzdem was erklären an deiner Formel? Wofür steht das alleinstehende "N" hinter Summenprodukt? Das habe ich so noch nirgendwo gesehen...
Antwortento top
#6
Hallo Al,

bei dem "N" handelt es sich um die Standard-Excefunktion N()
Diese Funktion wandelt WAHRheitswerte in Zahlenwerte.

Also wenn  z.B. A3="" als Ergebnis ein WAHR ergibt, dann ergibt =N(A3="") als Ergebnis eine 1 und wenn in A3 etwas gestanden hätte, dann wäre das Ergebnis eine 0.

Die Funktion N() kann natürlich auch für eine Matrix eingesetzt werden. Also ergibt eine Formel =N(A3:A9="") eine Matrix aus 6 Werten von 0 und oder 1. Diese können summiert werden, aber eine Matrix aus FALSCH und WAHR nicht. Somit war es notwendig meine Bedingungsprüfung mit dr Funktion N() zu "klammern.

Alternativ bzw. sehr oft wird anstelle der Funktion N() auch eine Multiplikation mit 1 oder Addition mit 0 oder eine doppelte Negation (also --) von einer WAHRheitsmatrix vorgenommen, welches natürlich das gleiche Ergebnis erzielt.
Gruß Werner
.. , - ...
[-] Folgende(r) 1 Benutzer sagt Danke an neopa für diesen Beitrag:
  • Al Swearengen
Antwortento top
#7
Hallo Al,

ich habe für dich einmal
Code:
=N
in einem leeren Tabellenblatt eingegeben. Und da sag einer, Excel sei nicht gesprächig. Wink     
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Al Swearengen
Antwortento top
#8
… wobei es ja durchaus einen Unterschied zwischen N() und der doppelten Negation (oder Addition von 0, Multiplikation mit 1, Potenzierung mit 1 …) gibt:
A
80
92
102
112
122

ZelleFormel
A8=N("2")
A9=--"2"
A10="2"+0
A11="2"*1
A12="2"^1

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
[-] Folgende(r) 1 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • Al Swearengen
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste