Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Frage: Daten richtig erfassen können
#1
Photo 
Guten Tag,

ich habe die Situation, dass ich in verschiedenen Zeilen die Zahlen 1-6 erfassen soll. Sobald mindestens eine Zahl davon in einer Zelle in einer Zeile auftaucht sollte diese Zeile mitgezählt werden, quasi als +1. Ohne die Zahlen soll die Zeile nicht erfasst werden, also+0. Wenn nur eine der gesuchten Zahlen in der Zeile ist, funktioniert es, aber sobald mehrere Zahlen vorhanden sind, zählt Excel halt +2,+3, usw.
Gibt es eine Möglichkeit, das Excel schlicht und ergreifend nur die Zeilen/Zeilenabschnitt zählt, in denen die Zahlen stehen und nicht die genaue Anzahl der Zahlen? Ich habe da momentan nämlich leider keine Idee.

Im Anhang habe ich einen der Beispielfälle angeführt, den ich gerade habe.
Ich danke für die Hilfe und hoffe, dass ich die Lösung im Forum nicht irgendwo übersehen habe.
VG


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hola,

und das Bild soll genau was darstellen?

Gruß,
steve1da
Antwortento top
#3
Hi

einen Rateversuch mach ich mal.
Code:
____|___A___|___B___|___C___|___D___|___E___|F|____G___|H|
   1|Spalte1|Spalte2|Spalte3|Spalte4|Spalte5| |Ergebnis|5|
   2|       |      2|       |      1|       | |        | |
   3|      0|       |       |       |      7| |        | |
   4|       |       |      0|      1|       | |        | |
   5|       |       |       |       |       | |        | |
   6|       |      5|       |      6|      2| |        | |
   7|       |       |      6|       |       | |        | |
   8|       |      4|       |      1|       | |        | |
Code:
H1    =SUMMENPRODUKT((MMULT(((A2:E8>0)*(A2:E8<7));MTRANS(SPALTE(A1:E1)^0))>0)*1)
Formel mit shift+strg+enter schiessen

Gruß Elex
Antwortento top
#4
Danke für die Antworten, bisher hat es noch nicht funktioniert, aber wahrscheinlich war ich noch nicht genau genug. Deshalb hier nochmal ein neues Bild.

In den Spalten O-S soll erfasst werden, ob  dort Eintragungen zwischen 0-6 (0 ist jetzt neu, sry) vorhanden sind. wenn dem so ist, soll für jede Spalte, in der das so ist, +1 gerechnet werden. Wenn also ,wie in diesem Fall, 18 Zeilen in dem Bereich O-S mindestens eine Zahl haben, soll auch 18 in der Summe rauskommen. Bei mir kommen halt in der Regel immer viel höhere Ergebnisse raus, da ich immer alle Zahlen in den Zeilen zähle und nicht wirklich weiß, wie ich es richtig machen kann.
Vielen Dank für die Antworten.

Gruß Morgomir


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#5
dann Versuch mal die Formel.
Code:
=SUMMENPRODUKT((MMULT(((O2:S32<>"")*(O2:S32<7));MTRANS(SPALTE(O1:S1)^0))>0)*1)
shift+strg+enter
Antwortento top
#6
Das hat funktioniert. Vielen DankSmile
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste