Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Fortlaufende Zahlen zuordnen
#1
Hallo,

mein Windows Programm kopiert Rennzeiten in eine 'Excel Tabelle.
Das macht es von oben nach unten in einer Spalte. Es schreibt in eine Zeile nach der anderen. Mehr kann es nicht.
Pro Spieler und Surchgang eine Zeit.

Im ersten Durchgang sind es 20-30 Spieler / Zeiten
Im zweiten sind es immer 10 Spieler / Zeiten.
Die Zeiten möchte ich zur Weiteren Verwendung in zwei Spalten aufteilen. 1. Durchgang 2. Durchgang. Der erste Durchgang ist für 20-30 Fahrer, der zweite Durchgang immer für 10 (top ten).
Mein Programm würde also bei 30 Spielern 40 Zeiten in 40 Zeilen einer Spalte ablegen

Bei Fester Spieleranzal wäre es kein problem die zahlen einfach mit meiner Rechentabelle zu verknüpfe (die ersten 30 in Durchgang 1 und die restlichen 10 in Durchgang zwei). Da es aber sein kann, dass weniger als 30 Spieler teilnehmen könnten, habe ich ein Problem bei der weiter Verknüpfung

Bei nur 27 Spielern, müsste schon ab der 28 Zeit in der Tabelle für 2. Durchgang weitergeschrieben werden.
Die Angabe der Spielerzahl ist in der Tabelle vorhanden

Wie könnte ich das lösen ?
   
Antwortento top
#2
Moin

Eine einfache Lösung wäre eine weitere Spalte "Durchgang" mit den Werten 1 oder 2.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Mein Programm weis leider nicht, ob Durchgang 1 oder 2 .
Die von Dir genannte zweite Spalte könnte ich aber mit Hilfe meiner Spielerzahlangabe ganz leicht ausfüllen.
Aber wie kann ich das dann anhand der zweiten spalte dem richtig Durchgangsspalte 1 und 2 in der zuordnen ?
Antwortento top
#4
Zwei Ansätze.
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJ
1Durchgang 1Durchgang 2Durchgang 1Durchgang 2
2WertDurchgang7474
31711171811718
42412242322423
52213222332223
62314231442314
7241524524
8231623623
9151715715
1018288
1123299
122321010
131421111

ZelleFormel
E3=WENNFEHLER(INDEX($A:$A;AGGREGAT(15;6;ZEILE($B$3:$B$13)/($B$3:$B$13=1);$D3));"")
F3=WENNFEHLER(INDEX($A:$A;AGGREGAT(15;6;ZEILE($B$3:$B$13)/($B$3:$B$13=2);$D3));"")
I3=WENN(H3<=$I$2;INDEX($A$3:$A$13;H3);"")
J3=WENN(H3<=$J$2;INDEX($A$3:$A$13;H3+$I$2);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Thumbs Up 
super,, das klappt sehr gut. Die zweite Spalte für Durchgang 1 und 2 zu differenzieren und dann mit Deiner Funktion zuordnen .

Vielen Dank
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste