Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel mit Makro einfügen
#1
Hallo, ich versuche eine Formel mit einem Makro in einer Zelle zu schreiben. Leider kommt immer eine Fehlermeldung 1004.

Diese Formel möchte ich in eine Zelle einfügen:

=WENN(UND(A1<>"";A1<>A2);SUMMEWENN(A:A;A1;C:C);"")

habe es auch auf englisch versucht:

=IF(AND(A1<>"",A1<>A2),SUMIF(A:A,A1,C:C),"")


Mit diesem Makro geht es leider nicht. 

Sub test()

Range("c1").FormulaLocal = "=WENN(UND(A1<>"",A1<>A2),SUMMEWENN(A:A,A1,C:C),"")"


End Sub



Wisst ihr da eventuell weiter?
Antworten Top
#2
Bei .Formula musst du auf amerikanische Schreibweise wechseln, also englische Formelnamen und Komma als Trenner
Bei .FormulaLocal bleibst du deutsch, also auch beim Semikolon als Trenner.

Auf alle Fälle müssen Anführungszeichen gedoppelt werden, wenn sie als Zeichen in einem String verwendet werden sollen.
Hat Dir mein Beitrag geholfen? Dann hilf auch Du - mit einer Spende an Wikipediadie Tafeln oder aktion-deutschland-hilft.de
[-] Folgende(r) 1 Nutzer sagt Danke an EarlFred für diesen Beitrag:
  • mf1633
Antworten Top
#3
Hi,

in Ergänzung zu EarlFreds Hinweis kannst Du hier z.B. auch mal nachlesen, wie man korrekt verkettet:

Strings bzw. Texte korrekt verketten (herber.de)
[-] Folgende(r) 1 Nutzer sagt Danke an {Boris} für diesen Beitrag:
  • mf1633
Antworten Top
#4
Hallo mf1639,

dir ist bewusst, dass du mit der Formel in C1, durch die Angabe C:C einen Zirkelbezug erzeugst?
Ändere den Bereich C:C, oder schreibe die Formel in eine andere Spalte
Hier dein Code mit Zirkelbezug:
Code:
Range("C1").FormulaLocal = "=WENN(UND(A1<>"""";A1<>A2);SUMMEWENN(A:A;A1;C:C);"""")"
Gruß Karl
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste