Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel in VBA Code umwandeln
#1
Hallo,

ich brauche -wie immer- Hilfe.

Kann mir helfen, die folgende Formel in eine VBA Code für einen Command Button umzuwandeln/umzuschreiben.

=WENN(C3>Pfändungstabelle!C291;(SVERWEIS(C3;Pfändungstabelle!A7:H241;WENN(C4>4;8;C4+3)))+C3-Pfändungstabelle!C291;SVERWEIS(C3;Pfändungstabelle!A7:H241;WENN(C4>4;8;C4+3)))


LG

Basti
Antwortento top
#2
HI,

Zeichne ein Makro auf...
lg Chris
Feedback nicht vergessen.
[Bild: v.gif]
3a2920576572206973742064656e20646120736f206e65756769657269672e
Antwortento top
#3
Hallo!

Macrorecorder finde ich nicht gut. Der zeichnet nur dieses dümmliche FormulaR1C1 auf anstatt das viel bessere Formula. Blush

Gruß, René
Antwortento top
#4
Hallo,

ich brauch hier wirklich ein VBA Code.
Antwortento top
#5
Hallo,

chris-ka hat dir doch gesagt, wie du zu deinem VBA-Code kommst!

Gruß Günter
aus der Helden-, Messe-, Musik-, Buch-, Universitäts- und Autostadt Leipzig
Antwortento top
#6
Hallo,

alternative, angenommen die Formel steht in Zelle A1 in einem Blatt, was aktiv ist.
Im Direktfenster (Strg+G) im VBA-Editor eingeben + Enter ...

?Range("A1").Formula

Gruß
Microsoft Excel Expert · Microsoft Most Valuable Professional (MVP) :: 01/2011 - 06/2019 :: 04/2020 - 06/2021
https://de.excel-translator.de/translator :: Online Excel-Formel-Übersetzer :: Funktionen :: Fehlerwerte :: Argumente :: Tabellenbezeichner (neu)
Antwortento top
#7
funktioniert leider nicht
Antwortento top
#8
Hallo,

welcher Vorschlag funktioniert nicht?
Gruß Stefan
Win 10 / Office 2007
Antwortento top
#9
Hallo, 19

entweder du schreibst die Formel in eine Zelle, ODER du evaluierst sie (getestet und läuft): 21

Code:
Option Explicit
Public Sub Main_1()
    Range("A2").Formula = "=IF(C3>Pfändungstabelle!C291,(VLOOKUP(C3,Pfändungstabelle!A7:H241,IF(C4>4,8,C4+3)))+C3-Pfändungstabelle!C291,VLOOKUP(C3,Pfändungstabelle!A7:H241,IF(C4>4,8,C4+3)))"
End Sub
Public Sub Main_2()
    MsgBox ActiveSheet.Evaluate("=IF(C3>Pfändungstabelle!C291,(VLOOKUP(C3,Pfändungstabelle!A7:H241,IF(C4>4,8,C4+3)))+C3-Pfändungstabelle!C291,VLOOKUP(C3,Pfändungstabelle!A7:H241,IF(C4>4,8,C4+3)))")
End Sub

Statt der MsgBox kannst du das Ergebnis auch einer Variablen zuordnen - oder was auch immer du machen möchtest. Dodgy
________
Servus
Case
Antwortento top
#10
Funktioniert - vielen Dank !!!!!  18
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste