Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel für folgendes Problem gesucht
#1
Hallo liebes Forum,

ich brauche dringend Hilfe! Mit welcher Formel bekomme ich so etwas hin?

Vorher:

[ Bild bitte als Datei hochladen! ]


Nachher:

[ Bild bitte als Datei hochladen! ]

Ich hoffe, hier kann mir jemand helfen!

Vielen dank!

Beste Grüße

Michael

So, nochmal:


Vorher:


.xlsx   Vorher.xlsx (Größe: 8,66 KB / Downloads: 18)



Nachher:


.xlsx   Nachher.xlsx (Größe: 8,91 KB / Downloads: 12)
Antwortento top
#2
Simpler ausgedrückt möchte ich folgendes machen:

Vorher:

        A           B
1   Wert1        abc
2   Wert1        def
3   Wert1        geh
4   Wert2        ijk
5   Wert3        lmn
6   Wert3        opq
7

Nachher:

        A           B           C          D           E
1   Wert1       abc        def        geh
2   Wert2       ijk
3   Wert3       lmn        opq
4
5
6
7

Vielen Dank schonmal für eure Hilfe!
Antwortento top
#3
D1: =EINDEUTIG(A1:A6)
E1[:E3]: =MTRANS(FILTER(B$1:B$6;A$1:A$6=D1))
Antwortento top
#4
Hallo LCohen,

danke für deine schnelle Antwort! Wie und wo muss ich die Formel(n) einsetzen? Wenn ich die erste Formel in das Feld D1 einsetze und die zweite Formel in E1 dann erscheint der Hinweis "Diese Funktion ist ungültig".

Vielen Dank!
Antwortento top
#5
Code:
Sub M_snb()
    sn = Sheet1.Cells(1).CurrentRegion
    ReDim sp(UBound(sn), UBound(sn))
   
   
    For j = 2 To UBound(sn)
      If sp(y, 0) <> sn(j, 1) Then
          y = y + 1
          t = 1
        End If
      sp(y, 0) = sn(j, 1)
      sp(y, t) = sn(j, 2)
      t = t + 1
    Next
   
    Sheet1.Cells(1, 4).Resize(UBound(sp), UBound(sp, 2)) = sp
End Sub
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antwortento top
#6
Dann probiere das ganze mal in Excel-für-das-Web aus. Dein xl2016 kennt die Funktionen nicht. Der Einsatzort steht vor der Formel.
Antwortento top
#7
Hallo Michael,

hier ein Formellösung, die auch für die 2016er Version funktioniert.

Formel in A2 zur Auflistung aller Unikate aus "Vorher":
=WENNFEHLER(INDEX(vorher!$A$2:$A$26;VERGLEICH(0;INDEX(ZÄHLENWENN($A$1:A1;vorher!$A$2:$A$26);0);0));"")
(nach unten ziehen)
Erklärung der Formel siehe hier:
https://www.xelplus.com/extract-unique-i...down-list/

Formel in B2:
=WENNFEHLER(INDEX(vorher!$B$2:$B$26;AGGREGAT(15;6;ZEILE(vorher!$B$2:$B$26)/(vorher!$A$2:$A$26=$A2)-1;SPALTE(A1)));"")
(nach rechts und nach unten ziehen)
Erklärung der Formel siehe hier:
https://www.xelplus.com/return-multiple-...-in-excel/

Siehe Beispieldatei


Angehängte Dateien
.xlsx   Formel Vorher Nachher_fs.xlsx (Größe: 14,96 KB / Downloads: 0)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste