Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel für Datumsabfrage
#1

.xlsx   Formel Datum.xlsx (Größe: 9,77 KB / Downloads: 1) Idea Hallo
Ich habe verzweifelt versucht was zu erstellen, bin aber kläglich gescheitert.

Ich habe die Tabelle mal ohne Formeln mit angehängt.

Im Feld H2 sollte das Datum aus G2 als Grundlage dienen. Es sollte dann in H2 die Tage aufgelistet werden, die seit dem Datum vergangen sind.

Als Beispiel heute 22.20.2020(G"= 01.10.2020 in F2 sollte jetzt stehen 22Tage).

Wenn dann F2 mit einem Datum gefüllt wird, dann sollte das zählen gestoppt werden und die beiden Daten verglichen werden und der Unterschied übernommen werden.

Wenn möglich sollte mit einer bedingten Formatierung die Hintergrundfarbe in H2 bei 0-13 Tage grün, bei Datum 14-19 Tage gelb und bei Datum ab 20 Tage rot sein.

Da es ein Firmenrechner mit der englischen Version von excel 2016 ist, benötige ich vllt die formeln in englisch (oder aber man kann das irgendwo finden).

Ich hoffe auf viele schlaue Köpfe.
Vielen Dank Bonnie
Antwortento top
#2
Moin!
Geht nur mit VBA, da in einer einzelnen Zelle nur entweder eine Formel oder ein Wert stehen kann!
(und ob dies auf dem Firmenrechner gestattet ist …?)

Anyway:
Die Differenz zum Datum in der Vergangenheit ist =HEUTE()-Datum+1

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#3
Hallo 
Danke für die Antwort. 

Mit der Formel =Heute()-Datum+1 bekomme ich einen falschen Wert.

Als Datum ist hier 11.10.2020 angegeben und als Ausgabe erhalte ich 13.01.1900.
Die Zellen sind auf Datum formatiert.

Ah ok 
Fehler gefunden. 
Format muss natürlich Zahl sein.
Danke

Noch eine Frage 
Wenn ich jetzt sagen will 

Wenn F2 leer dann heute - Datum sonst Datum-Datum.

Ich hoffe das ist einigermaßen verständlich und jemand hat eine Lösung. 
Danke
Antwortento top
#4
Hallöchen,

Code:
Wenn F2 leer dann heute - Datum sonst Datum-Datum.

=WENN(F2="";HEUTE();Datum-Datum)

wie auch immer man zu Datum-Datum kommt Smile
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • Bonnie und Clyde
Antwortento top
#5
Funktioniert Prima

Vielen Dank
Antwortento top
#6
Bin immer noch am optimieren. Die Formel funktioniert zwar, aber noch nicht zufriedenstellend. Habe nochmal eine versucht mit mehr Abfragen, aber become keinen Wert

Es soll lauten:

Wenn F2 leer dann leer Wenn F1 leer dann heute - Datum sonst Datum-Datum.

Das habe ich probiert:
=wenn(F2="";"")*wenn(F1="";TODAY()-F2;F1-F2)

Wie gesagt irgendwie funktioniert es so nicht. In der alten Formel (=WENN(F2="";HEUTE();Datum-Datum))bekomme ich im im Ausgabefeld 44127 angezeigt, wenn F1 und F2 leer sind

Hoffe das ist nicht zu kompliziert beschrieben
Antwortento top
#7
Hallöchen,

überdenke mal Diene Zusammenstellung.
Eine WENN-Formel geht in der Regel

=WENN(Bedingung;Dann;Sonst)

Also z.B. =WENN(F2="";"";wenn(F1="";TODAY()-F2;F1-F2))
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • Bonnie und Clyde
Antwortento top
#8
Super

Jetzt schein es perfekt für mich zu sein.

Vielen Dank
Antwortento top
#9
Ich verstehe momentan nicht, wie ein Mix aus deutschen und englischen Funktionsnamen funktionieren kann.
TODAY() ist auf deutsch HEUTE()
WENN() hingegen ist im englischen IF()
Ferner gibt es ja noch den unterschiedlichen Arguments-Trenner:
Englisch Komma
Deutsch Semikolon

Es grüßt ein verwirrter Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#10
Hi Ralf,

Der TE sieht durch. Die Sprache ändert am Prinzip ja nix... 17
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste