Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel Kombination IFERROR & VLOOKUP
#1
Guten Tag zusammen,
ich möchte 2 Formeln miteinander kombinieren. Vielleicht hat aber auch jemand eine bessere Idee Smile

Im Anhang findet ihr meine "Arbeit".
1) Kunde nimmt ein Produkt oder mehrere Produkte mit
2) Bei der Kundenzahlung möchte ich also den Preis für Produkt A und wenn vorhanden von Produkt B angezeigt bekommen
3) mit vlookup kommt aber eine Fehlermeldung, sobald ein Feld "LEER" ist. Das umgehe ich im Moment in dem ich überall "Keine Leistung" eintrage und in der Hilfstabelle ebenfalls "Keine Leistung" mit 0€ angebe.
4) Jetzt habe ich mich mal schlau gemacht und mit IFERROR gearbeitet. Das funktioniert, ABER nun springt mein vlookup nicht mehr in der Hilfstabelle zur entsprechenden Preis Spalte.

Wäre super wenn mir einer helfen könnte.

Danke und viele Grüße
Sebastian


Angehängte Dateien
.xlsx   ExcelFormelKombi.xlsx (Größe: 17,09 KB / Downloads: 4)
Antwortento top
#2
Hallo Sebastian,

das Problem liegt im Aufbau deiner Liste. Wenn du pro Vorgeng eine Zeile anlegst, wird alles funktionieren.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Hi Klaus Dieter,

danke für das schnelle Feedback.
Komme aber nicht drauf Smile Habe doch pro Kunden eine Zeile.

Meinst Du die Hilfstabellen zusammenwerfen?

Danke für Deine Hilfe.
Sebastian
Antwortento top
#4
Hi,

Arbeitsblatt mit dem Namen 'Sheet2'
ABCDEFGH
1KundeProdukt AProdukt BKundenzahlungHilfstabelle1
2Kunde AJuvederm 22,00 €Juvederm 15,00 €
3Kunde B-   €Juvederm 22,00 €
4Kunde CJuvederm 1Botox105,00 €Botox100,00 €
5Kunde DFäden120,00 €Fäden120,00 €

ZelleFormel
D2=WENNFEHLER(SVERWEIS(B2;$G$1:$H$5;2;0);0)+WENNFEHLER(SVERWEIS(C2;$G$1:$H$5;2;0);0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
Hallo,

ich meine das so:

ABC
1KundeProdukt Kundenzahlung
2Kunde AJuvederm 2              2,00 €
3Kunde B                   -   €
4Kunde CJuvederm 1              5,00 €
5Kunde CBotox          100,00 €
Formeln der Tabelle
ZelleFormel
C2=WENNFEHLER(SVERWEIS(B2;F$13:G$18;2;FALSCH);0)
C3=WENNFEHLER(SVERWEIS(B3;F$13:G$18;2;FALSCH);0)
C4=WENNFEHLER(SVERWEIS(B4;F$13:G$18;2;FALSCH);0)
C5=WENNFEHLER(SVERWEIS(B5;F$13:G$18;2;FALSCH);0)

FG
12Hilfstabelle1
13Juvederm 1       5,00 €
14Juvederm 2       2,00 €
15Botox  100,00 €
16Fäden  120,00 €

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#6
... war ja einfach. Smile
Hat endlich geklappt. Tausend Dank.

Gruß
Sebastian
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste