Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel-Bedingung: Nur einmal pro Monat -
#1
Hallo zusammen,


ich will die Bedingung in meine Formel einbinden, dass nur einmal innerhalb eines Monats ein "JA" ausgegeben wird, sonst kommt "NEIN" in die Zelle.


Die ursprüngliche Formel könnte lauten:


B1 =WENN(A1=1;"JA";"NEIN")


Jetzt soll aber nur einmal pro Monat ein "JA" eingetragen werden. Wenn A1=1 ist kommt in B1="JA"

Wenn in A2=1 und im gleichen Monat, dann soll aber statt "JA" ein "NEIN" ausgegeben werden.

Folglich für A3=1 ebenso "NEIN". Und erst wenn in A32 z.B. der neue Monat beginnt, wird für einen Wert von A32=1 wieder "JA" ausgegeben. Interessant wird es, weil ein Monat ja bekanntlich unterschiedlich viele Tage enthält. 
Neben meinen Werten sind die Daten


Kann mir jemand helfen? Vielen lieben Dank!
Antwortento top
#2
Hallo Timo!

Am einfachsten ist es, wenn du die Monate in einer Hilfsspalte ausgibst und diese dann abfragst: =WENN(ZÄHLENWENN($B$1:B1;B1)>1;"nein";"ja")

LG Alex
Antwortento top
#3
Hola,

was genau hat dich denn an meiner Antwort gestört?

https://www.herber.de/forum/messages/1745934.html

Gruß,
steve1da
Antwortento top
#4
das Problem auf diese Weise ist, dass Monate zwischen 28 und 31 Tage haben. Wenn ich also für einen Bereich =WENN(ZÄHLENWENN(B1:B31;B1)>1;"nein";"ja") eintrage, dann verrutschen mir die Monate...

Meine Datumangaben sind in Spalte C wie folgt aufgebaut: TT.MM.YYYY

Hey steve1da,

habe deine Antwort übersehen. Super! Das sollte funktionieren. Jetzt versuche ich die Formel in folgendes Schema zu integrieren:


A                                 B                                C

01.01.2020                  JA                   =WENN(SUMMENPRODUKT((MONAT(A2:A3660)<1)*(G2:G3660="BUY"));"NEIN";"JA")
02.01.2020                  JA
03.01.2020                  NEIN
etc
01.02.2020                  JA
02.02.2020                  NEIN


es soll also pro Monat max einmal "JA" stehen in Spalte C.
Kannst du da noch weiterhelfen?



Vielen lieben Dank!!!


=WENN(SUMMENPRODUKT((MONAT(A2:A3660)<1)*(G2:G3660="BUY"));"NO BUY";"BUY")
Antwortento top
#5
Hola,

welcher Monat (1-12) ist den kleiner als 1?

Gruß,
steve1da
Antwortento top
#6
Ahh, ich dachte es dreht sich um die Anzahl

Stimmt.

=WENN(SUMMENPRODUKT((MONAT(A2:A366)=1)*(A2:A366<>"")*(B2:B366="JA"));"JA";"NEIN") funktioniert bei mir noch nicht. ich hab die Werte einmal beispielhaft in einer Tabelle dargestellt. Habe ich etwas falsch übertragen?


Vielen Dank


Angehängte Dateien
.xlsx   JA NEIN .xlsx (Größe: 12,34 KB / Downloads: 5)
Antwortento top
#7
Hola,

du hast dich mit der Formel überhaupt nicht auseinandergesetzt oder?
Monat(...)=1 fragt auf den ersten Monat im Jahr ab. Januar. März wäre dann also?
Bei herber.de hattest du Excel gut angegeben.

Gruß,
steve1da
Antwortento top
#8
Meine Excel-Skills sind eigentlich recht gut. Mit der Monat-Funktion habe ich aber noch nicht gearbeitet. Ich will ja alle Monate betrachten und suche eine Formel, die ich nicht für jeden Monat umschreiben muss (was ja der Fall ist, wenn Jan = 1, Feb = 2 etc.). Hast du vielleicht noch eine Idee?

Angefügt habe ich ein Beispiel, um das Problem verständlicher zu machen.


Angehängte Dateien
.xlsx   JA NEIN .xlsx (Größe: 12,4 KB / Downloads: 1)
Antwortento top
#9
(13.03.2020, 17:10)TimoExcelCheck schrieb: Angefügt habe ich ein Beispiel, um das Problem verständlicher zu machen.
Fragen über Fragen ...

Warum stehen in B2 und B3 Zahlenwerte und in B4:B56 Textwerte (JA/NEIN)?
Am 01.04. ist bei B21="NEIN" die gewünschte Ausgabe "JA". Am 01.05. ist bei gleicher Konstellation die gewünschte Ausgabe "NEIN". Warum?
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#10
Ich habe mich etwas unverständlich ausgedrückt, sorry.

Ich will, dass in Spalte C immer die erste "1" des Monats übertragen wird. Ansonsten eine "2".




        A                         B                         C

     Datum                  Wert             Gesuchte Formel
     24.01.2020              2                         2
     25.01.2020              1                         1
     26.01.2020              1                         2
     27.01.2020              2                         2
     28.01.2020              2                         2
     29.01.2020              1                         2
     30.01.2020              1                         2
     31.01.2020              1                         2
     01.02.2020              2                         2
     02.02.2020              2                         2
     03.02.2020              2                         2
     04.02.2020              2                         2
     05.02.2020              1                         1
     (…)
     28.02.2020              2                         2
     01.03.2020              1                         1

     (…)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste