Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel Anzahl Tage wenn der Monat sich überschneidet
#1
[size=x-small][font=Verdana, Helvetica, Arial, sans-serif][size=small]Hallo zusammen,

ich habe Folgendes Problem:

Es gibt ein Datum, dass sich im Monat überschneidet 

27.02.2019
10.03.2019

Was ich brauche ist die Anzahl der Tage im Februar und März getrennt von einander abzüglich der Feiertage und Wochenenden.
Als Ergebnis müssten für Februar 2 und für März 6 rauskommen.
Für die weitere Verarbeitung ist es zwingend erforderlich, dass ich einen einzelnen Wert für Februar und einen Wert für März bekomme.
Ich habe mehrere Datumswerte die sich in den Monaten überschneiden und ich bräuchte eine allgemeine Formel.

Ich habe eine Hilftabelle mit allen Feiertagen 2019 und Spalten in der Exceltabelle vom 01.01.2019, 01.02.2019, 01.03.2019 etc.
Es gibt eine tolle Formel: 
A2 : =SUMMENPRODUKT((MONAT(ZEILE(INDIREKT($A$5&":"&$A$6)))=MONAT(A1))*1)

Das funktioniert fast perfekt, leider werden hier die Wochenenden und die Feiertage nicht abgezogen, als Ergebnis erhlate ich für Februar 2 und für März 10, weil logischerweise 2x Samstag und 2x Sonntag mitgezählt werden. So langsam verzweifel ich, so viele Versuche und ich bekomme es einfach nicht hin...
Hab schon Nettoarbeitstage und Nettoarbeitstage.intl in Verbindung mit der Formel oben, aber leider ohne Erfolg.


Ich hoffe es gibt hier jemanden, der mir bei meinem Problem helfen kann!
Von mir aus nur der Abzug der Wochenenden, Feiertage wären ein Bonbon [img]Dateiupload bitte im Forum - wie's geht: http://www.clever-excel-forum.de/thread-326.html .]
Antwortento top
#2
Hola,

zur Info.....

http://www.office-loesung.de/p/viewtopic.php?f=166&t=800655
https://www.ms-office-forum.net/forum/sh...p?t=359449
https://www.office-fragen.de/index.php/t...0.html#new
http://www.vba-forum.de/forum/View.aspx?...rschneidet

Gruß,
steve1da
Antwortento top
#3
(06.04.2019, 15:35)steve1da schrieb: Hola,

zur Info.....

http://www.office-loesung.de/p/viewtopic.php?f=166&t=800655
https://www.ms-office-forum.net/forum/sh...p?t=359449
https://www.office-fragen.de/index.php/t...0.html#new
http://www.vba-forum.de/forum/View.aspx?...rschneidet

Gruß,
steve1da

Sorry, ich dachte wenn ich meine Frage in mehreren Foren stelle, ist die Wahrscheinlichkeit höher, dass jemand die Lösung für mein Problem findet, dass mir seit ein paar Tagen Kopfschmerzen bereitet...
Antwortento top
#4
Hallo Chris,

fürs Verständnis: https://www.clever-excel-forum.de/misc.php?action=help&hid=10
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
(06.04.2019, 15:53)WillWissen schrieb: Hallo Chris,

fürs Verständnis: https://www.clever-excel-forum.de/misc.php?action=help&hid=10

Kann ich absolut verstehen, sorry, aber der Mod hätte es auch anders Lösen können und hätte micht darauf freundlich hinweisen können, wie du es tust. 
Leider prangert er mich mit hämischen Kommentaren an, was ist nicht in Ordnung finde.
Sorry fürs Crossposten, werde wenn es eine Lösung gibt, in allen Foren darauf hinweisen, die Verlinkung mit teilweise "netten" Kommentaren, hat der Mod bereits übernommen ;)
Antwortento top
#6
Hi,

ohne Feiertage:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
1vonbis1. Monat2. Monat
227.02.201910.03.201926
329.04.201907.05.201925

ZelleFormatWert
A2TT.MM.JJJJ27.02.2019
B2TT.MM.JJJJ10.03.2019
A3TT.MM.JJJJ29.04.2019
B3TT.MM.JJJJ07.05.2019

ZelleFormel
D2=NETTOARBEITSTAGE.INTL(A2;MONATSENDE(A2;0);1)
E2=NETTOARBEITSTAGE.INTL(DATUM(JAHR(B2);MONAT(B2);1);B2;1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#7
In diesem Forum, hat ein User eine optimale Lösung gefunden, mit seinem Einverständnis, kann ich wenn gewünscht die Formel veröffentlichen.

http://www.office-loesung.de/p/viewt...16971#p3216971


@WillWissen 
Vielen Dank für deine Zeit und Mühe. Eine super Lösung, die ich ebenfalls in meine Formelsammlung aufnehmen werde.
Antwortento top
#8
Kurzes Update:

Das ist die Lösung die mir ein User erarbeitet hat, vielen Dank dafür

Formel Spalte K: =WENN(MONAT(B2)<>MONAT(C2);NETTOARBEITSTAGE(B2;MONATSENDE(B2;0);feiertg);0)

Formel Spalte L: =NETTOARBEITSTAGE(DATUM(JAHR(C2);MONAT(C2);1);C2;feiertg)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste