Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Excel: Verschachtelte Abfrage
#1
Hallo zusammen,

leider bin ich gerade etwas am verzweifeln.
Ich habe eine Tabelle mit verschiedene Spalten (untersch. Geräte) und pro Spalte steht die Anzahl der dafür notwendigen Geräte drin.
Nun möchte ich gerne folgendes prüfen:
Solange die Anzahl der Geräte (Zeile 3, siehe Screenshot im Anhang) größer als 0 ist muss auch in Zeile 4 und 5 ein Preis enthalten sein. Es darf also kein Text eingetragen sein.
Die sollte die Formel für alle Geräte prüfen. 
Sobald bei einem Gerät die Anzahl höher als 0 ist und keine Kosten enthalten sind, soll ein Fehler ausgegeben werden.
Solange die Anzahl 0 ist und kein Preis enthalten ist, darf kein Fehler auftreten

Natürlich kann ich dies mit verschachtelten Wenn-Abfragen lösen, jedoch habe ich insgesamt über 20 Geräte und die Wenn-Abfrage würde dann wohl zu verschachtelt sein um einen Überblick zu erhalten.

Hat da jemand von euch eine Lösung?

Vielen Grüße
Phil


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hallo,

wenn ich mich nicht irre, kann man wenn 64-fach verschachteln. Wünsche viel Spaß dabei. Alternativ kannst du mal darüber nachdenken, ob dein Listenaufbau nicht optimiert werden könnte.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Oh, das kann heftig werden. 22
Leider kann ich den Aufbau nicht vereinfachen. Das ist schon die bestmögliche Darstellung  19
Antwortento top
#4
Hallo,


Zitat:Das ist schon die bestmögliche Darstellung


sagt wer? Stelle doch mal eine Beispieldatei ein, dann kann man  sehen, was man machen kann.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#5
Hallo,

im Anhang eine Beispieldatei.

Ich kann leider aber die Grundtabelle nicht mehr ändern, da es sich um unterschiedliche Produkte handelt.
Ebenso ist es möglich ,dass die Einträge, welche keine Zahl haben unterschiedlich ausfallen. Somit kann ich auch nicht nach z.B. "N/A" ausschließlich prüfen.

Viele Grüße
Philipp


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 9,9 KB / Downloads: 3)
Antwortento top
#6
(09.07.2020, 12:52)Phil_20 schrieb: Ich kann leider aber die Grundtabelle nicht mehr ändern, da es sich um unterschiedliche Produkte handelt.
Das ist kein valider Grund.

Platz für Hilfszeilen hat man immer.
Arbeitsblatt mit dem Namen 'Tabelle1'
BCDEFGHIJKLMNOPQRSTU
1GERÄTE
2Modell 1Modell 2Modell 3Modell 4Modell 5Modell 6Modell 7Modell 8Modell 9Modell 10Modell 11Modell 12Modell 13Modell 14Modell 15Modell 16Modell 17Modell 18Modell 19Modell 20
310230125068670187312
45,00 €5,00 €NA5,00 €5,00 €NoNA5No72,00 €No5,00 €1,00 €N/A6,00 €81,00 €86,00 €3,00 €NA1,00 €
51,00 €3,00 €-  €N/ANA-  €1,00 €N/A2,00 €2,00 €5,00 €1,00 €3,00 €2,00 €1,00 €NA12,00 €3,00 €5,00 €1,00 €
6
7WAHRFALSCHWAHRWAHRFALSCHWAHRWAHRWAHRFALSCHWAHRWAHRWAHRWAHRFALSCHWAHRWAHRWAHRWAHRWAHRWAHR
8WAHRWAHRFALSCHFALSCHFALSCHFALSCHFALSCHFALSCHFALSCHWAHRFALSCHWAHRWAHRFALSCHWAHRFALSCHWAHRWAHRFALSCHWAHR
90-1110111001000010010
10
118

ZelleFormel
B7=B3>0
B8=ANZAHL(B4:B5)=2
B9=B7-B8
B11=ZÄHLENWENNS(B9:U9;1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#7
Hallo Phil,

verstehst du jetzt, was ich meine?

Tabelle1

ABCDE
1Anzahl GeräteEinmalkostenMonatskosten
2Modell 11            5,00 €             1,00 €
3Modell 20            5,00 €             3,00 €
4Modell 32 NA                  -   € Fehler
5Modell 4 3            5,00 € N/A Fehler
6Modell 50            5,00 € NA
7Modell 61 No                  -   € Fehler
8Modell 72NA             1,00 € Fehler
9Modell 855 N/A Fehler
10Modell 90 No             2,00 €
11Modell 106          72,00 €             2,00 €
12Modell 118 No             5,00 € Fehler
13Modell 126            5,00 €             1,00 €
14Modell 137            1,00 €             3,00 €
15Modell 140 N/A             2,00 €
16Modell 151            6,00 €             1,00 €
17Modell 168          81,00 € NA Fehler
18Modell 177          86,00 €           12,00 €
19Modell 183            3,00 €             3,00 €
20Modell 191 NA             5,00 € Fehler
21Modell 202            1,00 €             1,00 €
Formeln der Tabelle
ZelleFormel
E2=WENN(UND(B2>0;ODER(ISTTEXT(C2);ISTTEXT(D2)));"Fehler";" ")
E3=WENN(UND(B3>0;ODER(ISTTEXT(C3);ISTTEXT(D3)));"Fehler";" ")
E4=WENN(UND(B4>0;ODER(ISTTEXT(C4);ISTTEXT(D4)));"Fehler";" ")
E5=WENN(UND(B5>0;ODER(ISTTEXT(C5);ISTTEXT(D5)));"Fehler";" ")
E6=WENN(UND(B6>0;ODER(ISTTEXT(C6);ISTTEXT(D6)));"Fehler";" ")
E7=WENN(UND(B7>0;ODER(ISTTEXT(C7);ISTTEXT(D7)));"Fehler";" ")
E8=WENN(UND(B8>0;ODER(ISTTEXT(C8);ISTTEXT(D8)));"Fehler";" ")
E9=WENN(UND(B9>0;ODER(ISTTEXT(C9);ISTTEXT(D9)));"Fehler";" ")
E10=WENN(UND(B10>0;ODER(ISTTEXT(C10);ISTTEXT(D10)));"Fehler";" ")
E11=WENN(UND(B11>0;ODER(ISTTEXT(C11);ISTTEXT(D11)));"Fehler";" ")
E12=WENN(UND(B12>0;ODER(ISTTEXT(C12);ISTTEXT(D12)));"Fehler";" ")
E13=WENN(UND(B13>0;ODER(ISTTEXT(C13);ISTTEXT(D13)));"Fehler";" ")
E14=WENN(UND(B14>0;ODER(ISTTEXT(C14);ISTTEXT(D14)));"Fehler";" ")
E15=WENN(UND(B15>0;ODER(ISTTEXT(C15);ISTTEXT(D15)));"Fehler";" ")
E16=WENN(UND(B16>0;ODER(ISTTEXT(C16);ISTTEXT(D16)));"Fehler";" ")
E17=WENN(UND(B17>0;ODER(ISTTEXT(C17);ISTTEXT(D17)));"Fehler";" ")
E18=WENN(UND(B18>0;ODER(ISTTEXT(C18);ISTTEXT(D18)));"Fehler";" ")
E19=WENN(UND(B19>0;ODER(ISTTEXT(C19);ISTTEXT(D19)));"Fehler";" ")
E20=WENN(UND(B20>0;ODER(ISTTEXT(C20);ISTTEXT(D20)));"Fehler";" ")
E21=WENN(UND(B21>0;ODER(ISTTEXT(C21);ISTTEXT(D21)));"Fehler";" ")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

PS: habe das noch mal optimiert.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#8
Hi zusammen,

super Danke für die Tipps.
Ich werde dies dann in meinen Tabellen so anpassen und die Hilfstabellen entsprechend einfügenSmile
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste