Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Excel Texte
#1
Hallo zusammen,

vielleicht kann mit jemand kurzfristig weiterhelfen.

Ich Suche eine Möglichkeit, gem. Beispiel, den Text mit gleicher Artikelnummer ein eine Zelle zu setzen. D.h. wenn die Artikelnummer identisch ist, soll der Text in eine Zelle eingefügt werden. Die Maximale Nummerierung liegt bei 40 (Zeilen).

Bei Art.-Nr. 123 wäre der Text dann "ghdehsdhrthrzutzjdthjktzukrzukizjkmfh".



[ Bild bitte als Datei hochladen! ]

.xlsx   Mappe1.xlsx (Größe: 9,77 KB / Downloads: 9)

Gruß
Matthias
Antwortento top
#2
Hallo Matthias,

s. Mappe

Sigi


Angehängte Dateien
.xlsx   NeuerText.xlsx (Größe: 10,45 KB / Downloads: 4)
Antwortento top
#3
Hallo Matthias,

die Artikelnummer in Zelle D2 und dann die Formel:
Code:
=TEXTKETTE(WENN(A2:A14=D2;C2:C14;""))

ACHTUNG: Wenn du die Sortierung deiner Liste änderst, ändert sich auch die Zeichenfolge.

Gruß,
Lutz
Antwortento top
#4

Tabelle1
ABCDEFGHI
1ArtikelnummerNummerText
21231ghdehsdh123ghdehsdhrthrzutzjdthjktzukrzukizjkmfh
31232rthrzutzj125ghjfghtzuieultzulkrzirzilrze4zetzilkrdzrzuilr
41233dthjktzuk128rtuirtuiketzuetue5zuiet
51234rzukizjkmfh
61251ghjfgh
71252tzuieul
81253tzulkrzi
91254rzilrze4z
101255etzilkrdz
111256rzuilr
121281rtuirtuik
131282etzuetu
141283e5zuiet
15

verwendete Formeln
Zelle Formel Bereich N/A
F2:F14=WENNFEHLER(TEXTVERKETTEN(;1;AGGREGAT(15;6;EINDEUTIG($A$2:$A$14);ZEILE()-1);FILTER($C$2:$C$14;$A$2:$A$14=AGGREGAT(15;6;EINDEUTIG($A$2:$A$14);ZEILE()-1)));"")
http://excel-inn.de/dateien/vba_beispiel..._addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit



Oder per Power Query zusammenführen.


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 19,22 KB / Downloads: 2)
Cadmus
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste