Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Excel: Text/Wörter nach Vokalen sortieren
#1
Moin, moin,

ich möchte aus einer Excel-Tabelle (nur Namen pro Feld)

1.) Wörter (alles nur Beispiele),

- die auf "a" enden
- die nur "i" und "e" enthalten
- die kein "o" oder "u" enthalten
- deren 1. Vokal ein "a" ist

herausfiltern und

2.) in Silben zerlegen sowie transponieren (eine Silbe pro Feld).

Gibt es dafür feststehende Funktionen? Oder wie ginge das...?

Danke für eure Bemühungen

(und auch Danke an steve1da !!! für die Hilfe!)
Antwortento top
#2
Moin,

hier mal ein Vorschlag für deine ersten drei Bedingungen:
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
1NamenEndung -amit -i und -eohne -o oder -u
2CarinaCarinaCarina
3CoronaCorona
4CoronakriseCoronakrise
5Ominös
6Umfang
7Oldenburg
8KemptenKempten
9Adenauer
10AngelAngel
11MeierMeierMeier
12Mario

ZelleFormel
B2=WENN(RECHTS(A2;1)="a";A2;"")
C2=WENN(UND(ISTZAHL(SUCHEN("i";A2));ISTZAHL(SUCHEN("e";A2)))=WAHR;A2;"")
D2=WENN(ODER(ISTZAHL(SUCHEN("o";A2));ISTZAHL(SUCHEN("u";A2)))=WAHR;"";A2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Für die Bedingungen 1. Vokal = a und Wörter in Silben trennen, fällt mir nichts ein.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • brainsurfer
Antwortento top
#3
Hier die Formel für die 4. Fragestellung (1. Vokal = A).

PHP-Code:
=WENN(WENNFEHLER(SUCHEN("a";A1);9)<WENNFEHLER(SUCHEN("e";WECHSELN(WECHSELN(WECHSELN(A1;"i";"e");"o";"e");"u";"e"));9);A1;""

Die Silbentrennung wird sich vermutlich nicht durch eine Formel realisieren lassen. Im folgenden Link wird einiges zur Silbentrennung erläutert.

https://www.duden.de/sprachwissen/rechts...rttrennung
VG, wisch
Wer Hilfe nimmt, sollte auch Hilfe geben! Auch wenn dies auf einem ganz anderm Gebiet geschieht.
Antwortento top
#4
Hola,

zur info...

http://www.office-hilfe.com/support/show...nd-filtern

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • brainsurfer
Antwortento top
#5
Vielen Dank für deine Info und deine Bemühungen!

Leider erst heute eine Antwort, weil
- ich Probleme hatte, die Antworten wiederzufinden
- ich auf einber spanischen Insel hocke und wir z.Z. ein sehr schlechtes Internet haben!

Einen schönen Sonntag noch

Gruß
brainsurfer
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste