Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

[Excel] Bereiche überprüfen, Case-Sensitive
#1
Es war die Frage aufgetaucht, wie man feststellen kann, ob ein Begriff aus einer Spalte in einer anderen Spalte in identischer Schreibweise (=Case Sensitive) zu finden ist. Die Funktion IDENTISCH, die Zeichenfolgen anhand ihrer ASCII-Codes vergleicht und somit Groß- und Kleinbuchstaben als unterschiedliche Zeichen betrachtet, arbeitet normalerweise nur über zwei Zellen, nicht aber über Zellbereiche. Ebenso arbeitet die Funktion FINDEN (und auch SUCHEN) nur in einzelnen Zellen. Alle drei Funktionen lassen sich aber auch über Bereiche anwenden. Dazu kann man die Universalfunktion SUMMENPRODUKT, in einzelnen Fällen auch SUMME (in der Matrixversion!) nutzen. Hier mal einige Beispiele:



Tabelle1

ABCDEFGHIJ
1AabAA2AusgangSucheZuordnung
2AAC3123-Aa-1144-b-18123-Aa-1112
3AcB123-A-2144-B-20123-A-21
4ACb123-aA-4144-B-24123-aA-41
5AAB123-aaa-4123-Aa-1123-aaa-41
6ASD123-AaA-5123-A-2123-AaA-51
7122-aaA-9123-aA-4122-aaA-91
8122-AAA-10123-aaa-4122-AAA-101
9144-B-11123-AaA-5144-B-111
10144-B-12122-aaA-9
11144-B-13122-AAA-10
12144-B-14144-B-11144-B-141
13144-B-17144-b-12144-B-171
14144-B-18144-B-14
15144-B-20144-B-17144-B-201
16144-B-21
17144-B-22
18144-B-23
19144-B-24 144-B-241
Formeln der Tabelle
ZelleFormel
C1=SUMMENPRODUKT(ISTZAHL(FINDEN($B$1;$A$1:$A$6))*1)
C2=SUMMENPRODUKT(ISTZAHL(SUCHEN(B1;$A$1:$A$6))*1)
H2=WENN(SUMMENPRODUKT(IDENTISCH($G$2:$G$19;F2)*1);F2;"")
I2=SUMMENPRODUKT(IDENTISCH($G$2:$G$19;F2)*1)
J2{=SUMME(IDENTISCH($G$2:$G$19;MTRANS($F$2:$F$19))*1)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8



In C wird geprüft, wieoft eine Zeichenfolge in den Zeilen eines Bereiches vorhanden ist. Mit FINDEN Case sensitive, mit SUCHEN Case insensitive.
In H und I wird geprüft, ob die Zeichenfolge einer Zelle in identischer Schreibweise enthalten ist, einmal indem sie dargestellt wird, einmal durch 1/0 für vorhanden/ nicht vorhanden. In J2 wird gezählt, wieviel Zeichenfolgen aus einer Spalte in einer anderen Spalte in identischer Schreibweise vorkommen. Funktioniert aber nur einwandfrei, wenn die Zeichenfolgen je Spalte ohne Duplikate vorhanden sind!
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 2 Gast/Gäste