Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Etiketten mit VBA füllen
#1
Hallo, 
ich arbeite gerade an einer VBA Anwendungen. Diese erstellt eine Tabelle in der jedes Bauteil untereinander aufgelistet ist. 
Nun die Schwierigkeiten für mich: die Daten jeder Zeile sollen auf einzelne Etiketten eingefügt werden. Auf dem Bogen sind 2x6 Etiketten aufgebracht.
Wie ich einzelne Werte untereinander wo  anderst einfüge weiß ich. Nur was soll ich machen wenn ein Satz Werte untereinander und nebeneinander eingefügt werden soll. Anbei mal ein Bild.
Der Seriendruck mit Word kommt aus Gründen nicht in Frage.

Über eure Hilfe würde ich mich sehr freuen.


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
gelöscht.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
??? Habe ich ein Thema übersehen?
Antwortento top
#4
Hallo

 Nur was soll ich machen wenn ein Satz Werte untereinander und nebeneinander eingefügt werden soll.
Ich versteh dich hiermit auch nicht, da dein schönes Bild mir auch nicht helfen kann.
Deine Datei wäre um einiges besser als das Bild.

Anmerkung:
Dazu ist Excel auch nicht das geeignete Programm.
Das hast du jetzt für deinen Drucker erstellt. Solltest du aber den Drucker wechseln, kommen erst die Probleme.

Gruss Guschti
Der Künstler lebt auch vom Applaus
[-] Folgende(r) 1 Benutzer sagt Danke an Guschti für diesen Beitrag:
  • legiminator
Antwortento top
#5
Moin!
(13.06.2020, 12:11)legiminator schrieb: Der Seriendruck mit Word kommt aus Gründen nicht in Frage.

Die der Herr aus genau welchen Gründen uns nicht nennen mag?

Man kann natürlich auch in Ansicht → Seitenlayout gehen und die einzelnen Breiten und Höhen in Zentimeter eingeben …
… aber erstens wird dies niemals so genau wie gewünscht (auch, wenn man 1,87 cm angibt) und zweitens kann (siehe Guschti) ein anderer Drucker die Frickelei wieder hinfällig machen.

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#6
Ok, ich versuche es mal so:

Jedes Bauteil soll ein Etikett bekommen. Pro Bauteil gibt es in der Übersicht eine Zeile in der alle nötigen Daten aufgelistet sind. Die Daten der einzelnen Bauteil sollen dann auf die Etiketten übertragen werden.
Für jeden Wert gibt es auf dem Etikett einen festen Platz. Jedes Bauteil bekommt nur ein Etikett.

Die Bögen auf denen die Etiketten aufgebracht sind haben ein DinA4 Format. Die Etiketten haben ein Format von 105x48mm. So ergibt sich eine Anordnung von zwei Spalten und 6 Zeilen auf dem Bogen.

Das übertragen der einzelnen Bauteile soll dann im Folgenden Schema ablaufen:

Bauteil 1     I   Bauteil 2
——————I—————-
Bauteil 3      I   Bauteil 4
—————-—I——————
Bauteil 5      I   Bauteil 6
——————I—————-
Bauteil 7      I   Bauteil 8
—————-—I——————



Bauteil 9     I   Bauteil 10
——————I—————-
Bauteil 11    I   Bauteil 12




Ich kann gerne eine Datei anhängen, ich denke das es aber vom Sinn her so einfache zu verstehen ist.

Ist natürlich immer schwierig wenn man im Thema ist, dann sieht man den Wald vor lauter Bäumen nicht mehr.

Gruß Flo
Antwortento top
#7
Hallo

Eher nein!

Gruss Guschti
Der Künstler lebt auch vom Applaus
Antwortento top
#8
wie hast du dir denn gedacht wie der Programmablauf sein könnte oder müßte? 

im ersten moment dachte ich an ein Masteretikett auf einem separaten Blatt. dort hinterlegst du verweise in die Zellen mit einer Variablen die dann mit einer bestimmten Zeilennummer gefüllt wird.

somit stehen dann Werte im Etikett. Dann kannst du die gesamte Range kopieren und in dein Druckblatt an einer der 8 Positionen einfügen, aber nur die Werte und Formate. Ob die Formeln noch funktionieren muß man testen. 

das ganze in eine Schleife verpackt bis deine 8 etiketten drauf sind  usw....
Antwortento top
#9
Hallöchen,

die Krux einer Formellösung ist, eine "mathematische" Regel zu finden, anhand der Du Deine Daten per Formel anordnen kannst. Ich habe hier mal ein einfaches Beispiel dazu. Es geht jeweils um einen 4-zeiligen Bereich, daher die Rechnung mit Rest und 4. Ich habe das jetzt mal mit WENN als Bedingungung formeliert Smile, könnte man eventuell auch direkt in der Zeilenangabe im INDEX berechnen ( INDEX(Bereich;Zeile;Spalte) ).
Die Daten aus A1:C3 werden damit entsprechend angeordnet, oberhalb und unterhalb hab ich immer je eine Zeile frei. Die Formel würdest Du in den zwei Zeilen eintragen und dann so weit wie nötig nach unten ziehen. Für Deine "2-spaltigen" Etiketten könnte man die Daten der ersten Zeile links, der zweiten Zeile recht, der dritten Zeile links usw. anordnen.

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1ABC
2DEFAC
3GHIB
4
5
6DF
7E
8
9
10GI
11H
12

ZelleFormel
E2=WENN(REST(ZEILE(A1);4)=1;INDEX($A$1:$C$3;(ZEILE()-2)/4+1;1);WENN(REST(ZEILE(A1);4)=2;INDEX($A$1:$C$3;(ZEILE()-2)/4+1;2);""))
F2=WENN(REST(ZEILE(A1);4)=1;INDEX($A$1:$C$3;(ZEILE()-2)/4+1;3);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#10
Guten Abend, 
Ich habe nun die Variante gewählt indem ich eine Vorlage gestaltet habe, in der die Werte einer Zeile übertragen werden. War für mich nun die einfachste Möglichkeit. Auch wenn diese nicht die sauberste ist. Das Ziel habe ich erreicht.

Vielen Dank für eure Hilfe.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste