Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Das Update ist abgeschlossen, Ihr könnt unser Forum jetzt wieder wie gewohnt nutzen. Eventuelle Bugs und Auffälligkeiten postet Ihr bitte im entsprechenden Forum im Bereich Forumstechnik. x


Ergebnis in Zahlenbereich suchen
#1
Hallo zusammen,

und Danke schon mal an jeden, der sich gedanklich durch dieses Problem durchkämpft. Auch für Lösungsvorschläge wäre ich dankbar.

Auf der angefügten Tabelle könnt ihr eine vereinfachte Version von meinem Problem sehen. Ich möchte in der linken Tabelle Werte eingeben. Excel soll dann diesen Wert nehmen und in der rechten Tabelle nachschauen, in welchem Bereich sich der Wert befindet, und dann entsprechend ein Ergebnis ausgeben und an die linke Tabelle zurückschicken.

Beispiel: Wert 1 ist 24. Damit liegt er im Bereich 21-40, damit ist das Ergebnis B.

Bei einem anderen Projekt hatte ich das gut mit der XVERWEIS-Funktion lösen können, da es in der rechten Tabelle nur feste Zahlen und keine Zahlenbereiche gab. Jetzt bräuchte ich das eben für Zahlenbereiche. Und natürlich für eine viel größere Datenmenge als in meinem Beispiel.

Die einzige Lösung, die mir einfällt, wäre eine Formel im Sinne von „Wenn Wert 1 größer gleich 21 und kleiner gleich 40, dann Ergebnis B“ (und entsprechend für die anderen Zahlbereiche), aber das würde für meine Datenmenge ewig dauern und komplette Handarbeit erfordern, ist also keine Option.

Relativ einfach möglich wäre es ja, die Zahlenbereiche in einzelne Spalten mit Minimal- und Maximalwert aufzuteilen. Gäbe es dann eine Möglichkeit, dass Excel für den eingegeben Wert in der linken Tabelle prüft, in welchem Bereich der Wert in der rechten Tabelle liegt und dann das entsprechende Ergebnis ausgibt?

Wie gesagt, für alle Denkanstöße wäre ich sehr dankbar!

Viele Grüße

Daniel


Angehängte Dateien
.xlsx   Problem.xlsx (Größe: 9,18 KB / Downloads: 5)
Antworten Top
#2
Hola,
das sind keine Zahlenbereiche, das ist alles TEXT.
Ist das in der Originaltabelle auch so? Kann das auf jeweils 2 Zellen aufgeteilt werden so dass dort richtige Zahlen stehen?
Gruß,
steve1da
Antworten Top
#3
Hi,

Code:
=XVERWEIS(B3;--INDEX(WECHSELN(LINKS($E$3:$G$5;2);"-";"");;VERGLEICH(A3;$E$2:$G$2;0));$H$3:$H$5;"";-1)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#4
Hallo

ich sehe es gibt bereits Lösungen, jetzt noch eine VBA Lösung von mir.
Leider eine alte Excel 2003 Datei, für das Makro spielt das keine Rolle.

mfg Gast 123


Angehängte Dateien
.xls   Problem.xls (Größe: 44 KB / Downloads: 2)
Antworten Top
#5
Hi,

noch 'ne Möglichkeit:

=XVERWEIS(B3;--TEXTVOR(FILTER($E$3:G$5;E$2:G$2=A3);"-");$H$3:$H$5;;-1)
Gruß,
Helmut

Win10 - Office365 / MacOS - Office365
Antworten Top
#6
Wow, vielen Dank, alle 3 Lösungen funktionieren hervorragend! Danke für die Unterstützung!
Antworten Top
#7
Leider bin ich jetzt doch noch auf ein Problem gestoßen, das ich nicht lösen kann. Die bisherigen Lösungen funktionieren bei den im Beispiel angegebenen Zahlenbereichen, aber leider nicht bei einzelnen Zahlen und bei dreistelligen Zahlen.
Genauer gesagt: Edgars Lösung
Code:
=XVERWEIS(B3;--INDEX(WECHSELN(LINKS($E$3:$G$5;2);"-";"");;VERGLEICH(A3;$E$2:$G$2;0));$H$3:$H$5;"";-1)

funktioniert bei einzelnen Zahlen in der rechten Tabelle, aber nicht bei dreistelligen, und Helmuts Lösung
Code:
=XVERWEIS(B3;--TEXTVOR(FILTER($E$3:G$5;E$2:G$2=A3);"-");$H$3:$H$5;;-1)

funktioniert mit dreistelligen Zahlen, aber nicht mit einzelnen.
Ich könnte natürlich die passenden Formeln für die jeweiligen Spalten verwenden, aber noch lieber wäre mir natürlich eine Formel für alles.
Ich habe die Beispieltabelle etwas angepasst, damit sie näher am Original ist. Hätte ich gleich machen sollen.
Außerdem habe ich noch die Variante eingefügt, in der die Zahlenbereiche auf 2 Spalten aufgeteilt sind. Es wäre zwar etwas Aufwand, alle Tabellen mit „Text in Spalten“ umzuwandeln, aber noch machbar. Falls es aber für die ungetrennte Variante eine Lösung gibt, wäre das optimal.
Und wieder vielen Dank im Voraus für Lösungen oder Vorschläge!
Viele Grüße
Daniel
 
 
 


Angehängte Dateien
.xlsx   Problem2.xlsx (Größe: 11,2 KB / Downloads: 2)
Antworten Top
#8
Hi,

Code:
=XVERWEIS(B3;--INDEX(WECHSELN(LINKS($E$3:$G$12;2+(B3>100));"-";"");;VERGLEICH(A3;$E$2:$G$2;0));$H$3:$H$12;"";-1)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#9
Blinksmiley Blinksmiley Blinksmiley Antwort nach 5 Minuten, und funktioniert natürlich perfekt! Vielen vielen Dank!
Antworten Top
#10
Hi,

bei meiner Methode wäre es:

=XVERWEIS(B3;--TEXTVOR(FILTER($E$3:G$12;E$2:G$2=A3);"-";;;1);$H$3:$H$12;;-1)
Gruß,
Helmut

Win10 - Office365 / MacOS - Office365
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste