Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Erfüllen von 2 Suchkriterien
#1

.xlsx   Mappe1.xlsx (Größe: 13,42 KB / Downloads: 7)
   

Hallo,

weiß jemand zu helfen mit welcher Formel-Kombi/Verschachtelung in Spalte C der Tab. 1 das richtige Umsatz-Ergebnis geliefert werden kann?

Es müssen die zwei Suchkritierien erfüllt sein:
1. Die Stadt muss übereinstimmen und
2. das Abrechnungsdatum (Spalte B) muss im Zeitraum Von/Bis der Tab. 2 liegen (Spalte F und G).

Es ist das erste Mal, dass ich in Excel nicht selbst zur Lösung komme, aber hier bin ich inzwischen mit meinem Latein am Ende. Blush
Wenn ich als 2. Suchkriterium lediglich eine Übereinstimmung des Datums abfragen würde, dann wäre das ja kein Problem, aber die Schwierigkeit hier liegt darin, dass das Abr.datum zwischen zwei Daten abgefragt werden muss.

Grüße
Antworten Top
#2
Hi,

mit Bildern kann man wenig anfangen. Stelle mal die Tabelle vor.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#3
Hi,

habe jetzt die Tabelle hochgeladen, die ich eigens für diese Fragestellung auf das Mindeste an Daten runtergebrochen habe.
Antworten Top
#4
Hallo f...,

für C3:

=SUMMENPRODUKT($H$3:$H$5*($E$3:$E$5=A3)*($F$3:$F$5<=B3)*($G$3:$G$5>=B3))
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antworten Top
#5
Moin!
Nur ergänzend die Alternative mit SUMMEWENNS()
Hierbei kann man problemlos ganze Spalten nehmen:

ABCDEFGH
1Tab. 1Tab. 2
2StadtAbr.datumUmsatzStadtVonBisUmsatz
3Frankfurt01.01.2022150,00Hamburg01.01.202131.12.2022100,00
4Frankfurt01.05.2022200,00Frankfurt01.01.202231.03.2022150,00
5Frankfurt01.04.202231.12.2022200,00

ZelleFormel
C3=SUMMEWENNS(H:H;E:E;A3;F:F;"<="&B3;G:G;">="&B3)
C4=SUMMEWENNS(H:H;E:E;A4;F:F;"<="&B4;G:G;">="&B4)

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antworten Top
#6
Hallo Helmut, Ralf,

recht herzlichen Dank! Beide Funktionen haben einwandfrei funktioniert.

1. Die Summenprodukt-Funktion kannte ich bisher gar nicht. Und sie ist so genial wie simpel. Smile
2. Die Summewenns-Funktion ist mir natürlich bekannt, aber mir war nicht bewusst, dass sie so flexibel in ihrer Gestaltung ist.

Ich habe einfach viel zu komplex gedacht mit SVERWEIS, INDEX, VERGLEICH etc..

Allerdings habe ich auch Glück, dass ich eine Zahl bzw. einen Betrag abfrage und nicht bspw. einen Text. Weil dann wäre es wohl doch ein wenig komplexer...

Danke Euch!
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste