Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Einzelne Tage als Zeitraum zusammenfassen mit Bedingung
#1
Hallo zusammen, 

ich habe folgendes Problem; ich habe Spalte A und B, in A ist eine Kennzeichnung und in B sind einzelne Tage erfasst. 
Die Daten möchte ich gerne in Zeiträume umwandeln, allerdings in Abhängigkeit von dem Wert in Spalte A:

So sieht die Grundtabelle aus
A               B
123     02.10.2020
123     03.10.2020
123     05.10.2020
123     12.10.2020
123     13.10.2020
123     14.10.2020
123     15.10.2020
456     03.10.2019
456     04.10.2019
456     15.09.2018

und so soll es am Ende aussehen: 
 A            B                       C
123     02.10.2020       05.10.2020
123     12.10.2020       15.10.2020
456     03.10.2019       04.10.2019
456     15.09.2018

Kann mir da jemand helfen?

Danke und viele Grüße, Tom
Antwortento top
#2
Bilder? XL-Dateien!
Antwortento top
#3
Grade noch mal angepasst Wink
Antwortento top
#4
456 bedarf Erläuterung. 123 aber auch, denn trotz Lücke machst Du einen Zeitraum draus.
Antwortento top
#5
123 und 456 waren nur als Platzhalter gemeint für z.B. Namen. Da könnte auch Meyer, Müller, Schmidt stehen. 
Es wäre nur wichtig, dass er nach diesen Platzhaltern die Zeiträume zusammen nimmt. Wenn z.B. zufällig 

Meyer      04.05.20
Schmidt   05.05.20 
Schmidt   06.05.20

da stehen würde, dürfte er nicht 

Meyer      04.05.20  06.05.20
Schmidt   ""

draus machen, sondern 

Meyer        04.05.20
Schmidt     05.05.20   06.05.20
Antwortento top
#6
Das war nicht die Antwort auf meine Rückfrage: Ich komme auf 3x 123, nicht nur 2x.
Antwortento top
#7
Wenn es nicht mehr als 100 Zeilen sind und in Zeile 1 begonnen wird, dann probier mal:

C1: =B1
C2: =WENN(UND(A2=A1;B2=B1+1);"";B2)
D1: =WENN(C2="";"";INDEX(B2:B101;VERGLEICH(1;MMULT(1*ISTZAHL(C3:C102);1);0);1))

und kopiere D1 und c2 hinunter.

Leider stimmt dieses Ergenis nicht mit Deinem Musterergebnis überein. Siehe auch LCohens Beitrag #4.

Gruss, Raoul
Antwortento top
#8
Hallo Tom, du hast um Hilfe gebeten und hast sie bekommen (war nicht leicht, aber sehr spannend). Ist damit Dein Problem gelöst oder funktioniert was nicht? Bitte um kurze Info. Bedankt hast Du Dich ja bereits praktischerweise gleich im Voraus bei der Fragestellung. Da kann man nicht meckern.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste