Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Eintrag in einer Matrix suchen wobei 2 Bedingungen zutreffen müssen
#1
Hallo,
ich benötige bitte eure Hilfe.

Ich habe eine Tabelle A3:AR25

ich habe ein zusätzliches Tabellenblatt als Hilfstabelle, dieses heisst YY, in der ersten Spalte von YY ist eine vierstellige Fahrzeug Code, in der zweiten Spalte von YY eine zweistellige Bauart Code und in der dritten Spalte von YY die Texterklärung hierzu.

Nun mein Problem: 
In der Hauptabelle steht der Wert für Fahrzeug Code in Spalte F und der Wert für Bauart Code in Spalte D. In der letzten Spalte (AR) der Haupttabelle möchte ich aus Tabellenblatt YY den passenden Texteintrag zu den Werten in den Spalten F und D der Haupttabelle darstellen. 

Ich habe alles mögliche versucht und bin kläglich gescheitert. Bitte um Hilfe.

Vielen Dank,
Eddie King
Antworten Top
#2
Hallo Eddi,

hast du es mal mit dem SVerweis versucht? Ansonsten Beispieldatei.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antworten Top
#3
Hallo,

ja wenn ich nur eine Bedingung hätte würde ich SVERWEIS nutzen. 
Aber hier müssen gleichzeitig 2 Suchbedingungen für einen Treffer berücksichtigt werden und da geht m.W. SVERWEIS nicht.
Antworten Top
#4
(11.05.2024, 13:01)eddie_ce schrieb: Aber hier müssen gleichzeitig 2 Suchbedingungen für einen Treffer berücksichtigt werden und da geht m.W. SVERWEIS nicht.
Da hast du vollkommen recht.

https://www.google.com/search?q=Eintrag+in+einer+Matrix+suchen+wobei+2+Bedingungen+zutreffen+m%C3%BCssen&sourceid=chrome&ie=UTF-8
Wir sehen uns!
... Detlef

Meine Beiträge können Ironie oder Sarkasmus enthalten.

Antworten Top
#5
Hi,

Zitat:Ich habe alles mögliche versucht


Glaube ich nicht:

INDEX/VERGLEICH
INDEX/AGGREGAT

Code:
=WENNFEHLER(Index(YY!C$1:C$100;Aggregat(15;6;Zeile($A$1:$A$100)/(YY!$A$1:$A$100=F3)/( YY!$B$1:$B$100=D3 );1);"n.v.")
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#6
Hi, da ich überhaupt nicht klar komme hier ein Beispiel Datei TEST.xlsx.

Früher habe ich das mit Index/Vergleich hinbekommen, aber beim besten Willen kriege ich das nicht mehr zusammen.

Danke für jegliche Hilfe.


Angehängte Dateien
.xlsx   TEST.xlsx (Größe: 18,61 KB / Downloads: 7)
Antworten Top
#7
Hi,

in F1 der Hauptabelle stehen keine Zahlen!

Ohne die Hilfsspalten:

Code:
=WENNFEHLER(INDEX(YY!C$1:C$49;AGGREGAT(15;6;ZEILE($A$1:$A$49)/(YY!$A$1:$A$49=--TEIL(B1;5;4))/( YY!$B$1:$B$49=--LINKS(B1;2));1));"n.v.")
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Nutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • eddie_ce
Antworten Top
#8
Edgar und andere Excel Experten, vielen Dank für die Antworten.

@Edgar - die Formel funktioniert wunderbar. Ich versuche krampfhaft nachzuvollziehen wie das Ganze funktioniert.
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste