Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Eine Information in mehreren Arbeitsblättern suchen
#1
Hallo!

ich bin neu hier und leider kein größerer Excel Pro. Ich habe jedoch ein Problem, bei dem ich einfach nicht weiter komme und nun Hilfe suche.

Ich habe eine Excel mit mehreren Arbeitsblättern. Alle Arbeitsblätter sind gleich aufgebaut, bis auch Blatt 1. 
Auf Blatt 1 habe ich ein Eingabefeld (Zelle D4). Gebe ich in dieses eine Materialnummer ein, so sollen mir darunter die Informationen A, B und C (Zelle D5-7) zu dieser Materialnummer erscheinen.

Die gesuchten Informationen befinden sich immer auf einer Zeile, aber irgendwo unter den anderen Arbeitsblättern.
Wie kann ich diese Informationen nun am Einfachsten über mehrere Arbeitsblätter hinweg suchen und mir anzeigen lassen?

Bisher verwende ich für jede gesuchte Information die Formel SVERWEIS. Für Information A verwende ich beispielsweise in der Suchmaske folgende Formel:
=SVERWEIS($D$4;Blatt2!B3:P150;2;FALSCH)        ->  Mit dieser Formel suche ich jedoch nur in einem Arbeitsblatt. Kann ich diese Formel noch erweitern? 

Mein Ziel: Spalte B aller Arbeitsplätter durchsuchen und mir bei einem Treffer die Informationen aus Spalte C, D oder F der jeweiligen Zeile anzeigen lassen.
Cool wäre es zudem, wenn bei erfolgloser Suche der Text "#NV" erscheinen würde.

Gibt es eventuell noch einen anderen/einfacheren Lösungsansatz, welchen ich noch nicht betrachtet habe?


Vielen Dank im Voraus.Smile
Gruß Tino
Antwortento top
#2
Zitat:ich bin neu hier und leider kein größerer Excel Pro.
Das macht nichts, wir diskriminieren hier niemanden wegen seiner Körpergröße.



Zitat:Ich habe eine Excel mit mehreren Arbeitsblättern. Alle Arbeitsblätter sind gleich aufgebaut, bis auch Blatt 1. 
...

Gibt es eventuell noch einen anderen/einfacheren Lösungsansatz, welchen ich noch nicht betrachtet habe?
Ja, gibt es. Es ist ein absolutes No-Go, gleichartige Daten auf mehrere Blätter aufzuteilen. Wieso das so ist? Das erlebst du gerade am eigenen Leib.

Gleichartige Daten gehören immer auf ein Blatt.
Schöne Grüße
Berni
Antwortento top
#3
Hallo Tino,

Eine Produktübersicht zuzüglich Stücklisten, Lieferanten, Arbeitsplänen usw. würde ich nicht unbedingt in eine Tabelle pressen wollen, wenn die Daten z.B. Produkteigenschaften sind, dann schon. Ich vermute auch letzteres, eventuell hast Du für jedes Material ein eigenes Blatt und willst da irgendwelche Daten in ein Formular einpassen?

Wenn die Information nur auf einem weiteren Blatt ist, kannst Du mehrere SVERWEIS verknüpfen. Es kommt ja nur bei einem was raus Smile

=WENNFEHLER(SVERWEIS(…);"") & WENNFEHLER(SVERWEIS(…);"") & WENNFEHLER(SVERWEIS(…

könnte aber sein, dass die Formel in einer Zelle irgendwann etwas zu lang wird. Dann müsstest Du sie auf mehrere Spalten aufteilen und diese dann zusammenfassen.

Wenn Deine Blätter z.B. mit der Materialnummer benannt sind kannst Du die Informationen gleich direkt mit INDIREKT abrufen Smile
UPS steht kommt hier aus der Tabelle 2020-0815, Zelle A1.

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
1Materialnummer2020-0815UPS

ZelleFormel
C1=INDIREKT("'" & B1 & "'!A1")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
@André: Darum habe ich "gleichartige Daten" geschrieben. Stücklisten, Lieferanten, Arbeitspläne sind nicht gleichartig, die gehören in separate Tabellen. Wenn - wie der TE schreibt - alle Blätter gleich aufgebaut sind, dann kann es sich eigentlich immer nur um einen Mix aus all dem handeln (zB ein Blatt je Produkt mit allen zugehörigen Informationen).
Aber es kann nicht zielführend sein, bei jedem neu angelegten Tabellenblatt sämtliche Formeln im Übersichtsblatt anpassen zu müssen und zu hoffen, dass meine keine übersieht.
Schöne Grüße
Berni
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste