Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Eindeutige Tage zählen mit mehreren Bedingung
#1
Guten Abend,

ich habe folgendes Problem:

Ich habe eine Tabelle mit den Einsätzen mehrer Mitarbeiter an mehreren Tagen. Ein Mitarbeiter kann auch mehrfach an einem Tag eingesetzt werden.
Gesucht wird nun die Anzahl an Tagen, an denen ein bestimmter Mitarbeiter in einem bestimmten Monat und Jahr eingesetzt wurde. Dabei sollen Mehrfacheinsätze an einem Tag nicht mehrfach gezählt werden.

Bspw: Peter Müller wurde eingesetzt:

1x am 16.09.2020
1x am 17.09.2020
2x am 18.09.2020
2x am 19.09.2020
1x am 01.10.2020

Gesucht werden nun die Einsätze im September 2020 des MA Peter Müller. Das Ergebnis müsste in F7 (siehe Anhang) 4 sein (da 4 unterschiedliche Tage im September 2020). Mitarbeiter, Monat und Jahr sollen flexibel gewählt werden können durch Eingabe, siehe in der Tabelle im Anhang F3, F4, F5.

Vielen Dank im Voraus!


Angehängte Dateien
.xlsx   CEF_bsp.xlsx (Größe: 8,94 KB / Downloads: 11)
Antwortento top
#2
Hallöchen,

hier mal das Prinzip:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
11MeierMeier2
21MeierMüller2
31MüllerMutzke1
42Müller
52Meier
63Mutzke

ZelleFormel
D1=SUMMENPRODUKT(($A$1:$A$99<>"")*($B$1:$B$99=C1)/ZÄHLENWENNS($A$1:$A$99;$A$1:$A$99&"";$B$1:$B$99;$B$1:$B$99&""))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • phily
Antwortento top
#3
=ANZAHL2(EINDEUTIG(FILTER(A1:A999;(TEXT(A1:A999;"JJJJM")=F4&F3)*(B1:B999=F5)))) mit XLWeb/GDocs/XL365 gleich schon als Ergebniszählung
Antwortento top
#4
Thumbs Up 
@schaun: Prinzip verstanden und auf mehrere Kriterien in der Tabelle angewendet. Funktioniert einwandfrei. Herzlichen Dank!!

@LCohen: Auch dir vielen Dank. Die Formel spuckt bei mir leider einen Fehler aus, kann aber an der anderen Excel Version liegen, an der ich grade sitze.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste