Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Dynamisches Dropdown - Quelle und Formel
#1
Liebes Excelforum,

besteht die Möglichkeit, eine INDIREKT-FORMEL im Datenüberprüfungsfenster (Typ: Liste) mit einer WENN-Formel zu kombinieren.

Bedeutet: Die INDIREKT-Formel wird nur angewendet wenn A1 Text beinhaltet. Ist A1 leer, wird eine Fehlermeldung angezeigt.
Antwortento top
#2
Hallöchen,

Siehe dazu in unserem Beispielbereich, Abhaengige-Dropdowns .
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
Hallo,

man kann bei => Datenüberprüfung => Liste schon eine Formel eingeben.
Die Formel muss halt einen eindimensionalen, zusammenhängenden Bereich zurückliefern.

Also z.B. so
=WENN($A$1<>"";Bereich1;Bereich2)

Siehe Beispieldatei

Gruß
Fred


Angehängte Dateien
.xlsx   Dropdown -Liste-mit Formel_fs.xlsx (Größe: 22,86 KB / Downloads: 5)
Antwortento top
#4
Hm, dann scheint Excel da keine Lösung zu haben bzgl. einer Doppel-Bedingung mit dynamischem Dropdown (indirekt-bezug).

Danke trotzdem für die Lösungen!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste