Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Dropdown Liste wenn Sverweis Fehler
#1
Guten Morgen,
bräuchte eine elegante lösung, wie ich eine Dropdown Auswahlliste erscheinen lasse wenn ein Datum kein Feiertag ist.

In Tabelle 1 spalte A1 steht ein Datum, in Tabelle "Feiertage" habe ich die daten der Feiertage. In Spalte B (tabelle 1) soll eine Dropdown liste erst angezeigt, wenn das datum in Spalte A kein feiertag ist.
Hab es erstmal mit diese Formel als quelle für die Dropdown liste versucht:
=Wennfehler(sverweis(a1;Feiertage!A2:c16;3;0);d5:d6)
Jedoch bekomme ich die Fehlermeldung:
Die Quelle muss eine getrennte Liste oder ein Bezug auf eine Zeile oder Spalte sein.
Antwortento top
#2
Hallo,

auch nachdem ich das mehrfach gelesen habe, habe ich nicht verstanden was du meinst. Lade doch bitte mal eine Beispieldatei hoch.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Hallöchen,

schreibe die Formel in eine Zelle und nimm diese als Bezug für das DropDown.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Hallo Rodrigo72 ,

so müßte es gehen (Formel für die Datenüberprüfung/Dropdown in Spalte B):
=WENN(ISTFEHLER(SVERWEIS(A1;Feiertage!$A$2:$C$16;3;0));$D$5:$D$6)

oder etwas kürzer so:
=WENN(ZÄHLENWENN(Feiertage!$A$2:$A$16;A1)=0;$D$5:$D$6)

Wenn dann das Datum in Spalte A ein Feiertag ist, bleibt die Dropdownliste dann leer

Siehe Beispieldatei

Gruß
Fred


Angehängte Dateien
.xlsx   bedingtes Dropdown_fs.xlsx (Größe: 12,57 KB / Downloads: 2)
Antwortento top
#5
Danke schonmal für eure mühe, habe mal eine Beispieldatei angefügt.

Ups 19
Wer lesen kann, ist klar im Vorteil!


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 11,7 KB / Downloads: 3)
Antwortento top
#6
Hallo Fred,

was du dir da ausgedacht hast, finde ich nicht so optimal. 

1. Das Vermischen unterschiedlicher Inhalte in einer Spalte ist immer schwierig. (Feiertage, Urlaub, Krank usw.)
2. Eintragen von Urlaub und / oder Krankheitstagen über ein Formularobjekt ist, wie ich meine, nicht praktikabel. (Willst du bei 30 Tagen Urlaub dreißig Mal eine Schaltfläche drücken)?

Habe dir mal zwei Alternativen für den Feiertag aufgezeigt. Das arbeitet beide Male mit dem SVerweis. Wenn du mit der Formel in Spalte B arbeitest, hast du keine Möglichkeit, dort gleichzeitig zum Beispiel eine Gültigkeitsregel anzuwenden. (Feiertage würden automatisch gekennzeichnet).

Als Alternative kann man, wie ich dort auch zeige, Feiertage mit einer bedingten Formatierung markieren, was dann Spalte B für die Urlaubs- und Krankheitstage frei macht.

PS: Leider hat die Darstellung nicht geklappt, im Original wird das Datum des 1. Januar in roter Fettschrift dargestellt, das kann die Excel-Jeanie nicht.

Tabelle1

AB
1Januar2020
2Datum
301.01.2020F
402.01.2020
503.01.2020
604.01.2020
705.01.2020
806.01.2020
907.01.2020
1008.01.2020
1109.01.2020
1210.01.2020
Formeln der Tabelle
ZelleFormel
A3=DATUM(B1;1;1)
B3=WENNFEHLER(SVERWEIS(A3;Feiertage!A$2:C$16;3;FALSCH);"")
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A31. / Formel ist =SVERWEIS(A3;Feiertage!$A$2:$A$16;1;FALSCH)Abc

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste