Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Dropdown Liste Leere Zellen ignorieren
#1
Hallo Leute

Will eine Dropdown Liste erstellen, in der Leere Zellen ausgeschlossen werden.

zb.

A1= a
A2= b
A3=
A4=
A5=e
A6=
A7=g

Das Problem ist, dass die Zellen A1 bis A7 alle eine Formel hinterlegt haben.
Aufgrund der Formel sind manche Zellen leer, andere nicht.

Bitte um Hilfe.

Vielen Dank.
LG N.
Antwortento top
#2
Hallöchen,

wenn Du die Formeln dort nicht ändern kannst dann nimm die Daten mit Autofilter per Formel ohne leere in einen anderen Bereich und verweise die Dropdown dort hin. #ZAHL bekommst Du mit WENNFEHLER weg.

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
1WerWer
2AA
3B
4BD
5DC
6#ZAHL!
7C

ZelleFormel
B1{=WENN(ZÄHLENWENN(A:A;"")<ZEILE(A1);"";INDEX(A$1:A$999;KKLEINSTE(WENN(ISTZAHL(SUCHEN("";A$1:A$999));ZEILE($1:$999));ZEILE(A1))))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste