Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Drei verschachtelte WENN Funktionen mit UND
#1
Hallo zusammen,

ich hab einen Knoten im Kopf und weiß nicht wie ich folgende Thematik umgesetzt bekomme.

Ich habe die folgende Tabelle zur Berechnung des Leistungssatzes von Kurzarbeit.
Folgendes müsste ich in D3 berechnen:

WENN E3<=3 UND B3 = OK DANN 60 SONST 67

WENN E3 >3 UND <7 UND B3=OK DANN 70 SONST 77

WENN E3 >=7 UND B3=OK DANN 80 SONST 87

Wie sieht das als Formel aus, ich checks nicht mehr.
Vielen Dank schon mal im Voraus. Smile 

VG Steff


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hola,

das kann man nicht verschalten, da spätestens nach dem SONST Schluss ist.
Ist die Bedingung erfüllt dann 60 und wenn sie nicht erfüllt ist 67. Excel hört genau hier auf zu prüfen weil entweder dass DANN oder das SONST der ersten Formel erfüllt ist.

Gruß,
steve1da
Antwortento top
#3
Moin

Code:
=WAHL(SUMME((MEDIAN(4;6;E3)=E3)*2;(E3<=3)*1;(E3>=7)*3);60;70;80)+(B3<>"OK")*7
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
=(KÜRZEN(ABS(E3-5)/2)+(E3>3)*2)*10+50+(B3<>"OK")*7

Mit der Präzisierung von E3 lässt es sich noch von 2 auf 1 Auftreten kürzen.
Antwortento top
#5
(doppelt ausgelöst)
Antwortento top
#6
Super vielen Dank für Eure schnellen Antworten, ich habe jedoch etwas im Gesetz übersehen.
Es wird noch komplizierter:

Das Ganze gilt nur wenn ein Mitarbeiter über 50 Prozent in Kurzarbeit war.
Falls das nicht der Fall ist dann fällt er je nachdem ob er mit Kind oder ohne Kind ist in diesem Monat auf den niedrigsten Leistungssatz runter.

Die Zelle D3 soll berechnet werden.

In logischen Worten:

WENN C3<50 DANN (WENN B3=OK DANN = B20(WENN B3=MK DANN = C20)) SONST die Formel von shift-del die da wäre:
=WAHL(SUMME((MEDIAN(4;6;E3)=E3)*2;(E3<=3)*1;(E3>=7)*3);60;70;80)+(B3<>"OK")*7

Danke nochmal und Sorry, wie man solche Gesetzte machen kann. Smile


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#7
Hat jemand eine Idee? Smile
Antwortento top
#8
Hallöchen,

die hattest Du doch schon Smile Wenn Du DANN und SONST durch Semikolas ersetzt und die Klammern beachtest und noch das eine oder andere mehr ....

=WENN(C3<50;(WENN(B3="OK";B20(WENN( ....

Falls in C3 nicht 50 steht sondern 50% könnte es in der Formel auch 0,5 sein ...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#9
Hallo zusammen,

ich bekomme das leider nicht hin. Ich bin zu doof.
Könnte mir jemand sagen, wie das als Formel aussieht?

Vielen, vielen Dank.
Antwortento top
#10
...

=WENN(C3<50;WENN(B3="OK";B20;WENN(B3="MK";C20;WAHL(SUMME((MEDIAN(4;6;E3)=E3)*2;(E3<=3)*1;(E3>=7)*3);60;70;80)+(B3<>"OK")*7)))
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste