Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Doppelte Zellen in unsortierter Liste addieren
#1
Hallo zusammen,

folgender, wahrscheinlich einfach zu lösender Case:

In Spalte A ist das Suchkriterium (z.B. Barcode).
In Spalte B ist die Liefermenge.
Die Liste ist nach Lieferdatum sortiert.

Aufgabe wäre die Gesamt-Liefermenge von jedem Barcode zu errechnen.

Wenn also Barcode 4711 mehrfach mit Mengen in der Liste steht, soll bei Barcode XY immer (aus Übersichtsgründen) in bspw. Spalte C die Gesamt-Liefermenge errechnet werden.
Wenn der Barcode nur einmal vorkommt, dann eben nur die Gesamtmenge bestehend aus einer Lieferung.

Der Ansatz, die Liste nach Barcode zu sortieren und händisch zu rechnen ist ausgeschlossen, da die Liste 3500 Zeilen besitzt  Confused

Ich finde die Aufgabe klingt logisch und einfach, aber ich krieg es nicht hin.


Vielleicht kann mir ja einer helfen.

Vielen Dank!
Antwortento top
#2
Verwende SUMMEWENN oder SUMMEWENNS.
VG, wisch
Wer Hilfe nimmt, sollte auch Hilfe geben! Auch wenn dies auf einem ganz anderem Gebiet geschieht.
[-] Folgende(r) 1 Benutzer sagt Danke an wisch für diesen Beitrag:
  • Jnkrn
Antwortento top
#3
Und wie genau?
Natürlich hab ich an Summewenn schon gedacht, nur welche Kriterien?
Antwortento top
#4
Moin

Oder Pivot.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • Jnkrn
Antwortento top
#5
Wenn in der Ersten Zeile die Überschriften stehen, folgende Formel in C2:
=SUMMEWENNS($B$2:$B$4000;$A$2:$A$4000;A2)
VG, wisch
Wer Hilfe nimmt, sollte auch Hilfe geben! Auch wenn dies auf einem ganz anderem Gebiet geschieht.
[-] Folgende(r) 1 Benutzer sagt Danke an wisch für diesen Beitrag:
  • Jnkrn
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste