Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Doppelte Nennungen abziehen aber wie?
#1
Hallo Leute,

ich stehe vor dem Problem doppelte Werte zu erkennen und diese entsprechend nicht mitzuzählen. 
Ich versuche es Beispielhaft zu erklären:

Ich habe 5 Bestellungen und es sind 10 bestimmte Arbeitsschritte möglich pro Bestellung. Jeder Arbeitsschritt wird einzeln pro Zeile dargestellt. So steht in Spalte A die Bestellnummer und in Spalte B der Arbeitsschritt. Jeder Arbeitsschritt hat eine bestimmte Dauer und ich möchte wissen, wie lange jede Bestellung im Schnitt benötigt. Dazu muss ich erkennen wir viel verschiedene Bestellnummern habe. Im nächsten Schritt möchte ich zudem noch erkennen, welcher Mitarbeiter wie lange im Schnitt für eine Bestellung benötigt und wie viele Arbeitsschritte er vollführt. Es sind nicht immer alle 10 Arbeitsschritte notwendig.
Die Daten werden automatisch von einer Sharepointseite gezogen und in eine Exell-Tabelle ausgegeben. Wir reden bei meinem Fall von ca. 60.000 bis 70.000 Zeilen mit ca. 30 Spalten an Datenmenge, die ausgewertet werden müssten. Das dauert derzeit aber so absurg lange, dass es nicht praktikabel ist.

Habt ihr da eventuell eine Lösung für mich?

Grüße

EDIT: Ich vergas zu erwähnen, dass eine VBA-Lösung nicht gewünscht ist.


Angehängte Dateien
.xlsx   TestVers..xlsx (Größe: 9,26 KB / Downloads: 21)
Antwortento top
#2
Hallo,

Zitat:Ich vergas zu erwähnen, dass eine VBA-Lösung nicht gewünscht ist.

dann versuche es mal mit Summenprodukt oder SummeWenn(s). Ich hätte das mit VBA gemacht.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Derzeit wird die Sache mit =IF(Countif(A2:[@Bestellnr.]:[@Bestellnr.]>1;"1";"") in einer weiteren Spalte gelöst. Dabei werden alle Mehrfachnennungen einer Bestellnr. mit 1 makiert. Diese Formel brauch aber unfassbar lange. Damit hätte ich aber zumindest die Anzahl von Bestllungen ermittelt in dem ich die Gesamtsummer aller Zeilen - die Summe der Dopllerneunngen nehme. Aber das ist leider keine Lösung, da noch mehr solcher Berechnungn stattfinden müssen. Über Pivot kann ich zumindest zahlenbasierte Werte aber keine Namen ausgeben. Z.B. würde ich gerne wissen, welche Bestllnr. von welchem Mitarbeiter bearbeitet wurde damit ich dem Mitarbeiter die Dauer dieser Bestellungen zuordnen kann. Das wird alles mit Summenprodukten und Summewenns einfach viel zu aufgebläht. Achjaaa... noch eines: Wir haben nur ein 32Bit-System und bekommen auch kein 64Bit-System.
Antwortento top
#4
Hallöchen,

da in Deinem Beispiel nicht ersichtlich ist, wie Du SUMMEWENNs und SUMMEPRODUKT einsetzt, hier erst mal ein Ansatz mit SUMMEWENN und ohne SUMMENPRODUKT. Einen Aufwand willst DU auch berechnen, der fehlt aber auch in Deinem Beispiel ....

Arbeitsblatt mit dem Namen 'Sheet1'
ABCDEFGHI
1BestellNr.ArbeitsschrittMitarbeiterAufwandBestellNr.ArbeitsschrittMitarbeiterAufwand
21231Müller00:011235Müller0:40:00
32345Müller00:022342Müller0:09:00
43455Müller00:033452Müller0:13:00
54568Schmidt00:044563Schmidt0:24:00
65674Schmidt00:055671Schmidt0:05:00
71235Müller00:06
82349Müller00:07
94562Schmidt00:08
101238Müller00:09
113456Müller00:10
121233Müller00:11
134565Schmidt00:12
141239Müller00:13

ZelleFormel
F2=MIN(A:A)
G2=ZÄHLENWENN(A:A;F2)
H2=SVERWEIS(F2;A:C;3;FALSCH)
I2=SUMMEWENN(A:A;F2;D:D)
F3=WENN(MAX(A:A)=MAX(F$2:F2);"";KGRÖSSTE(A:A;ZÄHLENWENN(A:A;">"&F2)))
G3=ZÄHLENWENN(A:A;F3)
H3=SVERWEIS(F3;A:C;3;FALSCH)
I3=SUMMEWENN(A:A;F3;D:D)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
Moin

Kein Wunschergebnis.
Keine bisherigen Formeln. Die im Beitrag genannte Formel kann nicht eingegeben werden.
Keine Zeitangaben.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste