Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Differenz mit negativen Datum
#1
Hallo.
ich habe eine Tabelle mit verschiedenen Datums-Werten. Zu beachten ist immer eine Frist von 7 Tagen bzw. 5 Arbeitstagen.

In der Tabelle habe ich jeweils einen Beginn und ein Ende. Fristen habe ich schon durch Ampelsymbole hinbekommen. Allerdings bekomme ich sobald ein Wert in der Vergangenheit liegt eine Fehlermeldung
Meine Zielstellung ist der Reihenfolge nach erste Spalte=Startdatum, zweite Spalte=Differenz zwischen Startdatum und aktuellem Datum; bei >7 Tage grüne Ampel bei 7-5 Tagen gelbe Ampel und bei kleiner als 5 Tagen rote Ampel.
Dritte Spalte=Enddatum; vierte Spalte=Differenz zwischen Enddatum und aktuellem Datum; bei >7 Tage grüne Ampel bei 7-5 Tagen gelbe Ampel und bei kleiner als 5 Tagen rote Ampel.
Fünfte Spalte=Dauer in Tagen zwischen aktuellem Datum und Enddatum.
Danke für eure Hilfe.
Antwortento top
#2
Hola,

zeig bitte eine Beispieldatei (kein Bild).

Gruß,
steve1da
Antwortento top
#3
Hallo ,


Zitat:Allerdings bekomme ich sobald ein Wert in der Vergangenheit liegt eine Fehlermeldung

Was soll den dann passieren , wie ist deine Logik, wie kann es vorkommen das Werte in der Vergangenheit liegen.
Antwortento top
#4
Hallo,

Bilder gehen nur über URL einzufügen!? habe das mal als xlsx angefügt Smile

Angenommen das Enddatum ist der 22.06.2019 und das Anfangsdatum ist der 07.06.2019... da gibt es zwar eine 1904 Funktion bei Optionen aber die liefert dann auch nur falsche Werte.


Angehängte Dateien
.xlsx   Änderungen Zeitgesteuerte Ansagen 2.xlsx (Größe: 12,84 KB / Downloads: 5)
Antwortento top
#5
Hola,

bei DATEDIF() muss das erste Datum immer kleiner sein als das 2. Datum.
Und das ist beim 07.06.2019 gegeben.

Gruß,
steve1da
Antwortento top
#6
(11.06.2019, 07:45)steve1da schrieb: Hola,

bei DATEDIF() muss das erste Datum immer kleiner sein als das 2. Datum.
Und das ist beim 07.06.2019 gegeben.

Gruß,
steve1da

Hallo, in meiner Tabelle steht das Enddatum ja auch hinter dem Startdatum, war vielleicht bisschen unverständlich geschrieben,
Glaube auch nicht dass es durch die DATEDIF Funktion geht, vielleicht eher mit einer Wenn Funktion oder ähnlichem.

Es würde ja auch reichen wenn die Zellen bei dieser Fehlermeldung leer blieben, so weiß man zumindest dass es sich um ein Datum aus der Vergangenheit handelt... Fehlermeldungen sind immer etwas verwirrend Wink
Antwortento top
#7
Hallo,

versuche es mal so:

Tabelle1

GHIJ
1BeginnRestEndeRest
2
308.06.2019315.06.20194
430.06.20191912.08.201962
513.06.2019227.06.201916
601.07.20192030.08.201980
722.06.20191105.07.201924
811.11.201915322.12.2019194
911.06.2019030.07.201949
1017.06.2019629.06.201918
1107.06.2019408.08.201958
1221.09.201910231.12.2019203
1313.04.20195930.05.201912
Formeln der Tabelle
ZelleFormel
H3=WENN(A1>G3;DATEDIF(G3;A1;"d");DATEDIF(A1;G3;"d"))
J3=WENN(A1<I3;DATEDIF(A1;I3;"d");DATEDIF(I3;A1;"d"))
H4=WENN(A2>G4;DATEDIF(G4;A2;"d");DATEDIF(A2;G4;"d"))
J4=WENN(A2<I4;DATEDIF(A2;I4;"d");DATEDIF(I4;A2;"d"))
H5=WENN(A3>G5;DATEDIF(G5;A3;"d");DATEDIF(A3;G5;"d"))
J5=WENN(A3<I5;DATEDIF(A3;I5;"d");DATEDIF(I5;A3;"d"))
H6=WENN(A4>G6;DATEDIF(G6;A4;"d");DATEDIF(A4;G6;"d"))
J6=WENN(A4<I6;DATEDIF(A4;I6;"d");DATEDIF(I6;A4;"d"))
H7=WENN(A5>G7;DATEDIF(G7;A5;"d");DATEDIF(A5;G7;"d"))
J7=WENN(A5<I7;DATEDIF(A5;I7;"d");DATEDIF(I7;A5;"d"))
H8=WENN(A6>G8;DATEDIF(G8;A6;"d");DATEDIF(A6;G8;"d"))
J8=WENN(A6<I8;DATEDIF(A6;I8;"d");DATEDIF(I8;A6;"d"))
H9=WENN(A7>G9;DATEDIF(G9;A7;"d");DATEDIF(A7;G9;"d"))
J9=WENN(A7<I9;DATEDIF(A7;I9;"d");DATEDIF(I9;A7;"d"))
H10=WENN(A8>G10;DATEDIF(G10;A8;"d");DATEDIF(A8;G10;"d"))
J10=WENN(A8<I10;DATEDIF(A8;I10;"d");DATEDIF(I10;A8;"d"))
H11=WENN(A9>G11;DATEDIF(G11;A9;"d");DATEDIF(A9;G11;"d"))
J11=WENN(A9<I11;DATEDIF(A9;I11;"d");DATEDIF(I11;A9;"d"))
H12=WENN(A10>G12;DATEDIF(G12;A10;"d");DATEDIF(A10;G12;"d"))
J12=WENN(A10<I12;DATEDIF(A10;I12;"d");DATEDIF(I12;A10;"d"))
H13=WENN(A11>G13;DATEDIF(G13;A11;"d");DATEDIF(A11;G13;"d"))
J13=WENN(A11<I13;DATEDIF(A11;I13;"d");DATEDIF(I13;A11;"d"))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
[-] Folgende(r) 1 Benutzer sagt Danke an Klaus-Dieter für diesen Beitrag:
  • darkblue2404
Antwortento top
#8
Hola,

=wennfehler(DEINE_FORMEL;"")

@Klaus-Dieter: etwas kürzer:
Code:
=DATEDIF(MIN(A1;G3);MAX(A1;G3);"d")


Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • darkblue2404
Antwortento top
#9
Hallo Steve,

OK, OK, mit VBA wäre mir das eher nicht passiert.  Blush
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#10
Hallo,

Danke für die Formel.

Ein Punkt hätte ich da aber noch.

Die Resttage aus der Vergangenheit werden Positiv dargestellt. Bsp. H3 (3)müsst doch eigentlich -3 heißen, aber das geht wohl nicht?
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste