Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Details aus einer Liste zusammenfassen und ausgeben?
#1
Vielleicht kann mir jemand helfen, wie ich folgende Aufgabe lösen kann.  
Die Liste rechts im Bild kann nicht geändert oder bearbeitet werden. Sie ist auch sehr lang und das ende der Spalten nicht voraus sagbar. Aus dieser Liste muss ich die Informationen für die Linke Tabelle zusammen stellen.
Für die roten Zahlen suche ich jetzt den Weg.

   
Antwortento top
#2
Hallo,

das geht zum Beispiel mit der Funktion Summenprodukt. Lade deine Beispieldatei, von der du das Bild gemacht hast, hoch, dann zeige ich dir wie das geht.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Hallo,

das ginge je nach dem mit den Funktionen ZÄHLENWENNS() UND SUMMENWENN()

Gruß Uwe
Antwortento top
#4

.xlsx   TEIL07.xlsx (Größe: 9,06 KB / Downloads: 4)

ich habe die Datei mal angehangen.
Antwortento top
#5
Hallo,

so etwa:

Sheet1

ABCDEFGHIJKLMN
1DatumBestellerSpezialkostFrühstückLunchpaket
2BestellerFrühstück LunchPaketVegetarierVeganerLaktoseMoslem04.08.2020Kindergarten Moslem160
3Kindergarten 666008101604.08.2020Kindergarten 3260
4Knapp44000004.08.2020Kindergarten Laktose100
5Koch65120004.08.2020Kindergarten Veganer80
6Kohl40000004.08.2020Knapp44
7Schmidt1212003004.08.2020KochVegetarier10
804.08.2020Koch35
904.08.2020KochVeganer20
1004.08.2020Kohl40
1104.08.2020SchmidtVegetarisch412
1204.08.2020Schmidt50
1304.08.2020SchmidtLaktose30
Formeln der Tabelle
ZelleFormel
B3=SUMMENPRODUKT(($K$2:$K$13=$A3)*($M$2:$M$13))
C3=SUMMENPRODUKT(($K$2:$K$13=$A3)*($N$2:$N$13))
D3=SUMMENPRODUKT(($K$2:$K$13=$A3)*($L$2:$L$13=D$2)*($M$2:$N$13))
E3=SUMMENPRODUKT(($K$2:$K$13=$A3)*($L$2:$L$13=E$2)*($M$2:$N$13))
F3=SUMMENPRODUKT(($K$2:$K$13=$A3)*($L$2:$L$13=F$2)*($M$2:$N$13))
G3=SUMMENPRODUKT(($K$2:$K$13=$A3)*($L$2:$L$13=G$2)*($M$2:$N$13))
B4=SUMMENPRODUKT((K$2:K$13=A4)*(M$2:M$13))
C4=SUMMENPRODUKT(($K$2:$K$13=$A4)*($N$2:$N$13))
D4=SUMMENPRODUKT(($K$2:$K$13=$A4)*($L$2:$L$13=D$2)*($M$2:$N$13))
E4=SUMMENPRODUKT(($K$2:$K$13=$A4)*($L$2:$L$13=E$2)*($M$2:$N$13))
F4=SUMMENPRODUKT(($K$2:$K$13=$A4)*($L$2:$L$13=F$2)*($M$2:$N$13))
G4=SUMMENPRODUKT(($K$2:$K$13=$A4)*($L$2:$L$13=G$2)*($M$2:$N$13))
B5=SUMMENPRODUKT((K$2:K$13=A5)*(M$2:M$13))
C5=SUMMENPRODUKT(($K$2:$K$13=$A5)*($N$2:$N$13))
D5=SUMMENPRODUKT(($K$2:$K$13=$A5)*($L$2:$L$13=D$2)*($M$2:$N$13))
E5=SUMMENPRODUKT(($K$2:$K$13=$A5)*($L$2:$L$13=E$2)*($M$2:$N$13))
F5=SUMMENPRODUKT(($K$2:$K$13=$A5)*($L$2:$L$13=F$2)*($M$2:$N$13))
G5=SUMMENPRODUKT(($K$2:$K$13=$A5)*($L$2:$L$13=G$2)*($M$2:$N$13))
B6=SUMMENPRODUKT((K$2:K$13=A6)*(M$2:M$13))
C6=SUMMENPRODUKT(($K$2:$K$13=$A6)*($N$2:$N$13))
D6=SUMMENPRODUKT(($K$2:$K$13=$A6)*($L$2:$L$13=D$2)*($M$2:$N$13))
E6=SUMMENPRODUKT(($K$2:$K$13=$A6)*($L$2:$L$13=E$2)*($M$2:$N$13))
F6=SUMMENPRODUKT(($K$2:$K$13=$A6)*($L$2:$L$13=F$2)*($M$2:$N$13))
G6=SUMMENPRODUKT(($K$2:$K$13=$A6)*($L$2:$L$13=G$2)*($M$2:$N$13))
B7=SUMMENPRODUKT((K$2:K$13=A7)*(M$2:M$13))
C7=SUMMENPRODUKT(($K$2:$K$13=$A7)*($N$2:$N$13))
D7=SUMMENPRODUKT(($K$2:$K$13=$A7)*($L$2:$L$13=D$2)*($M$2:$N$13))
E7=SUMMENPRODUKT(($K$2:$K$13=$A7)*($L$2:$L$13=E$2)*($M$2:$N$13))
F7=SUMMENPRODUKT(($K$2:$K$13=$A7)*($L$2:$L$13=F$2)*($M$2:$N$13))
G7=SUMMENPRODUKT(($K$2:$K$13=$A7)*($L$2:$L$13=G$2)*($M$2:$N$13))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#6
Danke für den Tip. Ich Liste die ich tatsächlich machen muss ist um viele spalten größer, aber nun hab ich eine gute Grundformel. DankeSmile

Edit: A3 müsste auch von einer Formel erfasst werde, da sich ja namen immer beim import der rechten Tabelle ergeben
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste