Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Datumfelder farbig über die Heute Funktion
#1
hallo zusammen,
gibt es eine Möglichkeit per Formatierung Excel zu sagen,
wenn unter die Heute funktion in a1 das Datum identisch ist mit
den Datumsangaben,dann sollen die Felder farbig werden.
Also,ist heute der 1.6.20,dann soll am 4.6 die Farbe wieder verschwinden.
Und das möchte ich über die ganzen Datumfelder anwenden.

Danke
Antwortento top
#2
Hallo,

das ist generell über die bedingte Formatierung möglich. Bei deinem Tabellenaufbau aber viieeel unnötige Arbeit, weil du für jede Urlaubsperiode eine neue Bedingung erstellen musst.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
hei,
könnte man nicht auch das u als Anhaltspunkt nehmen?
na dem Motto,wenn ein u in der zeile,dann markiere mir den passenden monat?

Danke
Antwortento top
#4
Hola,

was für ein 4.6.? Der ist doch gar nicht im Blatt vorhanden? Und warum soll dann der 3.6. auch markiert werden?
Was hat es mit dem Datum in A1 wirklich auf sich?

Gruß,
steve1da
Antwortento top
#5
@steve1da
hallo,in A1 ist die heute funktion.
Ich hab sie nur manuell eingegeben. zum 1.6
Der 1.6 ist der Urlaubstart.Und da erscheint dann in der Statusanzeige das U.
das U bleibt so lange steh'n,bis der 3.6 vorbei ist.
Also,soll die Farbmarkierung am 4.6 nicht mehr erscheinen.
Und das nächste U wird dann am 14.7 erscheinen,da wieder jemand im Urlaub ist.
Auch hier wieder eine Farbmarkierung.
Usw,usw...
Die Farbmarkierung dient zur schnelleren Findung.
Danke
Antwortento top
#6
Hallöchen,

da beißt sich was …

Zitat:a dem Motto,wenn ein u in der zeile,dann markiere mir den passenden monat?

Zitat:Der 1.6 ist der Urlaubstart.Und da erscheint dann in der Statusanzeige das U.
das U bleibt so lange steh'n,bis der 3.6 vorbei ist.
Also,soll die Farbmarkierung am 4.6 nicht mehr erscheinen.

Ansonsten hier mal eine Variante:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGH
101. Jun02. Jun03. Jun04. Jun05. Jun06. Jun
201. Jun03. Junuuu
305. Jun05. Junu
ZelleFormel
C2=WENN(UND(C$1>=$A2;C$1<=$B2);"u";"")
Zellebedingte Formatierung...Format
C11: ZÄHLENWENN(C$2:C$3;"u")abc
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#7
@schauan
moin,danke für deine Mühe.
Deine Zellenformel hat mich weiter gebracht.
Auf meine Datei umgesetzt,lautet diese bei Anwendung der Heutefunktion =WENN(UND($A$1>=H13;$A$1<=I13);"u";"")
Deine Bed.Form. hätte dazu geführt,das auch die älteren Datums weiter markiert bleiben,obwohl die Us sich ausblenden.
Daher habe ich die Formel angewendet: =h14="u"
Das war auch meine Vorstellung. s.Anhang
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste