Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Datum Zeit als Keterium
#1
Moin zusammen,

wie Ihr im Anhang sehen könnt, habe ich in der Spalte A ein Datum was sich in der Spalte x wiederfindet.
Ich möchte in der Spalte D3 das ergebniss aus Spalte y haben nach den Keterium Spalte A.
z.B.
Spalte D3 = Suche in der Spalte X nach dem Keterium A2 und gebe die Summe aus Spalte Y

Mit Summeprodukt oder SUMMEWENNS habe ich es nicht hinbekommen.
Endweder bekomme ich eine 0 oder ein #NV.

Gruß
Jürgen


Angehängte Dateien
.xlsx   Zeit als Kreterium.xlsx (Größe: 125,87 KB / Downloads: 4)
Antwortento top
#2
Hallo
du hast in Spalte X nicht nur das Datum sondern auch die Uhrzeit mit drin. Daher passt der vergleich mit dem Datum nicht ohne weiters.
so sollte es gehen
=SUMMENPRODUKT((GANZZAHL($X$2:$X$1400)=$A3)*$Y$2:$Y$1400)

Gruß Holger
[-] Folgende(r) 1 Benutzer sagt Danke an echo für diesen Beitrag:
  • JürgenRa
Antwortento top
#3
Moin Jürgen,

als Erstes musst du die Datumsspalte X als reines Datum umformatieren (aktuell hast du dort Datum und Uhrzeit stehen). Siehe in meinem Tabellenausschnitt Spalte AA. Kopiere AA und füge sie in X als Werte wieder ein. Danach kannst du mit SUMMEWENN() berechnen.

Arbeitsblatt mit dem Namen 'Tabelle1'
NXYZAA
31.098.338 m²02.01.201918378802.01.2019
4-02.01.201915876102.01.2019
502.01.201913610802.01.2019
602.01.201919330802.01.2019
702.01.201920013702.01.2019
802.01.201922623602.01.2019

ZelleFormel
N3=SUMMEWENNS(Y3:Y1346;X3:X1346;A3)
AA3=DATUM(JAHR(X3);MONAT(X3);TAG(X3))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • JürgenRa
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste