Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Datum Excel VBA
#1
Guten Tag zusammen,

gibt es eine Möglichkeit bei Excel im VBA eine Datumsgenerator zur erstellen?

Folgende Aufgabe:

In Excel wird über ein Commandbutton ein VBA Programm zum ausrechnen von Zinsen geschrieben.
Jetzt gibt es aber auch die Möglichkeit den ursprünglichen Betrag in Raten zu bezahlen. D. H. pro Rate 
kommt eine gewisse Höhe an Zinsen hinzu.

Jetzt möchte man über den Commandbutton die Zahldaten eingeben- jeweils zum ersten eines Monats, begrenzt auf zwei Jahre.

Es müsste also in den Zeilen 2 - 29 (z. B.) die jeweils Monatsersten angeben werden.

Also z. B. wenn man in Zeile 2 den 01.04.2020 einträgt dann bis zum 01.04.2022 automatisch eingefügt wird (nur jeweils der Monatserste immer) und 
wenn die Raten weniger als 24 Monate betragen - z. B. nur 8 Monate- das man dies auf die in einer Zelle angegeben Zahl der Raten beschränken kann.

Ist das möglich?

Viele Grüße

Basti
Antwortento top
#2
Hallo Basti,

muss es unbedingt VBA sein?

Hier mal ein Formelansatz:
Arbeitsblatt mit dem Namen 'Tabelle1'
AB
101.01.20205
201.02.2020
301.03.2020
401.04.2020
501.05.2020
6
7
8
9
10

ZelleFormel
A2=WENN(ZEILE()<=$B$1;DATUM(JAHR(A1);MONAT(A1)+1;1);"")
A3=WENN(ZEILE()<=$B$1;DATUM(JAHR(A2);MONAT(A2)+1;1);"")
A4=WENN(ZEILE()<=$B$1;DATUM(JAHR(A3);MONAT(A3)+1;1);"")
A5=WENN(ZEILE()<=$B$1;DATUM(JAHR(A4);MONAT(A4)+1;1);"")
A6=WENN(ZEILE()<=$B$1;DATUM(JAHR(A5);MONAT(A5)+1;1);"")
A7=WENN(ZEILE()<=$B$1;DATUM(JAHR(A6);MONAT(A6)+1;1);"")
A8=WENN(ZEILE()<=$B$1;DATUM(JAHR(A7);MONAT(A7)+1;1);"")
A9=WENN(ZEILE()<=$B$1;DATUM(JAHR(A8);MONAT(A8)+1;1);"")
A10=WENN(ZEILE()<=$B$1;DATUM(JAHR(A9);MONAT(A9)+1;1);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
Moin und off topic!
In einem aktuellen Excel oder Excel-Online reicht eine einzige Formelzelle:

AB
1Monatserste24
201.05.2020
301.06.2020
401.07.2020
501.08.2020
601.09.2020
701.10.2020
801.11.2020
901.12.2020
1001.01.2021
1101.02.2021
1201.03.2021
1301.04.2021
1401.05.2021
1501.06.2021
1601.07.2021
1701.08.2021
1801.09.2021
1901.10.2021
2001.11.2021
2101.12.2021
2201.01.2022
2301.02.2022
2401.03.2022
2501.04.2022
26

ZelleFormel
A2=EDATUM("1/5/20";SEQUENZ(B1)-1)

   

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#4
(15.10.2020, 13:26)Basti567 schrieb: gibt es eine Möglichkeit bei Excel im VBA eine Datumsgenerator zur erstellen?

Hallo, 19

prinzipiell so: 21

.xlsb   WorkSheet_Change_Datum_Eingabe_Ausgabe_der_Erste_jeden_Monats_InputBox_CEF.xlsb (Größe: 15,94 KB / Downloads: 1)

Statt der InputBox kannst du natürlich auch den Wert aus einer Zelle einlesen. Confused
________
Servus
Case
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste