Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Datenreihe in Intervalle aufsplitten und deren Laufzeit angeben
#1
Hallo,

ich habe eine Excel Tabelle mit Daten zu einem Abwasserfilter. Eine Spalte gibt die Laufzeit in Stunden an. Während der Filter gereinigt wird ist die Laufzeit = 0.
Daraus ergibt sich dann eine Ausgabe von 0, 0, 0, 0.25, 0.5, (...), 5, 5,25, 0, 0, 0.25, (...).

Ich möchte jetzt auf einem neuen Sheet die Anzahl und Länge der Intervalle ausgeben. 

Bei der gegeben Zahlenreihe hat der erste Intervall z.B. ein Länge von 5,25 Stunden.

Die Ausgabe soll dann wie folgt aussehen:

Erste Spalte:

Intervall 
1
2
(...)

und in der nächsten Spalte:

Länge Intervall
5,25
6
4,5

Ich habe mir überlegt das ganze mit einer if-Bedingung zu lösen bei der ein Intervall über die Bedingung Wert.Laufzeit n >= Wert. Laufzeit n+1 mit dem Startwert n=1 definiert ist. Die erste if-Schleife würde ja dann solange laufen bis der erste 0er-Wert des zweiten Intervalls anfängt, also genau der Intervalllänge entsprechen. Der letzte Wert der if-Schleife wäre ja dann auch genau die gesuchte Länge des Intervalls für die zweite Spalte in der Ausgabe. Leider weiß ich nicht wie ich das mit Excel Befehlen umsetzten kann.
Antwortento top
#2
Hallo,

angenommen, der Bereich ist A1:A50, wo die Werte drinstehen. Dann könntest Du probieren, wenn ich das richtig verstanden habe ...

Code:
B1=1
B2=WENN(A2>A1;B1;WENN(A2<A1;B1+1;B1))
B3=AutoAusfüllen von B2 usw.

D1=1
E1=MAX(WENN($B$1:$B$50=D1;$A$1:$A$50;0))  als Matrixformel !
D2=2
E1=AutoAusfüllen von E1 usw.

Gruß
Microsoft Excel Expert · Microsoft Most Valuable Professional (MVP) :: 01/2011 - 06/2019 :: 04/2020 - 06/2021
https://de.excel-translator.de/translator :: Online Excel-Formel-Übersetzer :: Funktionen :: Fehlerwerte :: Argumente :: Tabellenbezeichner (neu)
Antwortento top
#3
Es ist mir ein Rätsel, wie du aus:

Zitat:0, 0, 0, 0.25, 0.5, (...), 5, 5,25, 0, 0, 0.25, (...).

auf die Intervalllängen:
5,25
6
4,5

kommst.

Mit einer Mustermapppe, die aue händisch ermittelte Sollergebnisse zeigt, lässt sich viel besser arbeiten bzw. das Poblem nachvollziehen !!!
VG, wisch
Wer Hilfe nimmt, sollte auch Hilfe geben! Auch wenn dies auf einem ganz anderem Gebiet geschieht.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste