Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Daten-Zusammenstellung zu bestimmten Stichpunkt-Zeiträumen
#1
Hallo,

ich habe ein recht komplexes Problem für das ich derzeit noch nicht so recht weiss, wie ich das lösen kann.

Ich habe eine grosse Tabelle - nennen wir sie "Tabelle 1" mit folgenden Informationen:

Spalte A: Personal-Nr.
Spalte B: Eintrittsdatum
Die weiteren Spalte sind für diese Betrachtung nun nicht relevant.

In einer weiteren Tabelle, nennen wir sie "Tabelle 2" habe ich die folgenden Informationen:

Spalte A: Personal-Nr
Spalte B: Umsatz-Datum
Spalte C: Umsatz Typ X
Spalte D: Umsatz Tyb Y
Spalte E: Umsatz Typ Z

Anzumerken wäre noch, dass zu einem bestimmten Datum nicht notwendigerweise Umsätze von allen Typen gibt. Oft ist z. B. hinter einem Datum auch nur ein Umsatz Typ X und zu einem anderen Datum Umsatz Typ Z und die Felder in den anderen Spalten sind leer.

Ziel ist es nun, für jeden Mitarbeiter zu bestimmten Zeitpunkten (alle 3 Monate) die Informationen aus Tabelle 2 auszulesen und in einer neuen Tabelle (Tabelle 3) übersichtlich zusammenzustellen. Diese Tabelle sollte enthalten:
Spalte A: Personal-Nr
Spalte B: 3-Monats-Wert
Spalte C: 6-Monats-Wert
Spalte D: 9-Monats-Wert
usw.

Der bestimmte Zeitpunkt ist jeweils alle 3 Monate. Um eventuelle Ferien und Feiertage nicht zum Problem werden zu lassen, wurden diese 3 Monate definiert als Zeitfenster von 90 +/-5 Tage. Die Schwierigkeit, für die ich bisher keine Lösung habe ist, dass das Datum für diese Betrachtung für jeden Mitarbeiter unterschiedlich sein soll, nämlich beginnend mit dem Eintrittsdatum (also nicht einfach statisch ein Datum für alle) und dass ich dann mit diesem Zeitfenster von 90 Tage +/- 5 Tagen umgehen muss (für Spalte B in Tabelle 3 bzw. eben 180 Tage +/-5 Tage für Spalte C in Tabelle 3, usw)

Hat vielleicht jemand eine schlaue Idee, wie man das lösen kann?

Selbst wenn es nur ein Hinweis für eine Teillösung ist, die mich dem Ziel näher  bringt, wäre ich bereits dankbar.
Antwortento top
#2
Hola,

eine Excel-Beispieldatei wäre hilfreich.

Gruß,
steve1da
Antwortento top
#3
Beispieldatei im Anhang


Angehängte Dateien
.xlsx   Beispieldatei.xlsx (Größe: 12,53 KB / Downloads: 8)
Antwortento top
#4
Hola,

meinst du das so?

Code:
=SUMMENPRODUKT((Tabelle2!$A$2:$A$10=A2)*(Tabelle2!$B$2:$B$10>=SVERWEIS(A2;Tabelle1!$A$2:$B$7;2;0)+85)*(Tabelle2!$B$2:$B$10<=SVERWEIS(A2;Tabelle1!$A$2:$B$7;2;0)+95)*(Tabelle2!$C$2:$E$10))
Dies ist erstmal für Stichprobe 1.

Gruß,
steve1da
Antwortento top
#5
Hi


Frage war falsch verstanden. Idea


Gruß Elex
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste