Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

DATEDIV funktioniert nicht richtig
#1
Tach erst mal.

Ich mache/bastel ja eigentlich alles in Excel. Aber warum in der angefügten Tabelle, in Zeile 15 die Tage falsch berechnet werden verstehe ich nicht.

Eventual kennt ja noch jemand das Problem und hat eine Lösung.

MfG vaterderhuehner


Angehängte Dateien
.xlsx   DateDiv.xlsx (Größe: 9,22 KB / Downloads: 10)
Antwortento top
#2
Hi,

ich verstehe dein Problem nicht - es kommt doch das richtige Ergebnis raus? Huh 

Als Vergleich habe ich die Formel aus excelformeln.de verwendet.

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
1617.07.201706.01.20202 Jahre, 5 Monate, 20 Tage
1717.07.201706.01.2020Alter: 2 Jahre, 5 Monate, 20 Tage

ZelleFormel
E16=WENN(DATEDIF(A16;B16;"y")>0;DATEDIF(A16;B16;"y") & " Jahre, " & DATEDIF(A16;B16;"ym") & " Monate, " & DATEDIF(A16;B16;"md") & " Tage ";DATEDIF(A16;B16;"ym") & " Monate, " & DATEDIF(A16;B16;"md") & " Tage")
E17="Alter: "&DATEDIF(A17;B17;"y")&" Jahr"&WENN(DATEDIF(A17;B17;"y")<>1;"e";"")&", "&DATEDIF(A17;B17;"ym")& " Monat"&WENN(DATEDIF(A17;B17;"ym")<>1;"e";"")&", "&TAG(B17)-TAG(A17)+(TAG(A17)>TAG(B17))*TAG(DATUM(JAHR(A17);MONAT(A17)+1;))&" Tag"&WENN(TAG(B17)-TAG(A17)+(TAG(A17)>TAG(B17))*TAG(DATUM(JAHR(A17);MONAT(A17)+1;))<>1;"e";"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallo
habe die Probe gemacht und zum Datum 17.07.2017 von A15 zwei Jahre , fünf Monate und zwanzig Tage addiert:
=DATUM(JAHR(A15)+2;MONAT(A15)+5;TAG(A15)+20)
Das Ergebnis ist 06.01.2020

Kann das Ergebnis deine Formel also auch nur bestätigen. Das Ergebnis stimmt
Gruß Holger
Antwortento top
#4
Äh Sorry

aber auf meinem Monitor sieht das so aus:
   

ändere ich das Datum z. B. auf den 06.02   dann rechnet Excel wieder richtig.

Verstehe ich nicht. Gut, werde die Datei mal auf einem anderen PC testen.

Danke für eure Hilfe

Gruß vaterderhuehner

Dinge guibt es !

Also die Datei in Office 2010 geöffnet, kein Problem.

OK, nochmals danke und gute Nacht.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste