Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Berechnung Lagerdauer
#1
ich habe die folgende Abbildung in einer Zelle versucht.

Leider habe ich es nicht geschafft. er schreibt zu viele Argumente

Wie im Anhang gezeigt versuche ich das folgende zu berechnen

Berechnungsdatum ist B1

in der Spalte D sollen die Anzahl an Tagen der Ware auf Lager berechnet werden.

Bedingung 1:    Beispiel Zeile 7   - Einlagerung und Auslagerung gleiches Monat ( C1-A1 )

Bedingung 2:    Beispiel Zeile 8    - Einlagerung vor dem aktuellen Monat ( Berechnung Anzahl der Tage des aktuellen Monats)

Bedingung 3:    Beispiel Zeile 9  - Einlagerung vor dem aktuellen Monat ( Berechnung Anzahl der Tage im aktuellen Monat)

ist das in einer Zelle so überhaupt machbar?


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Erstmal Hallo,

(26.01.2019, 10:29)pege78 schrieb: Leider habe ich es nicht geschafft. er schreibt zu viele Argumente
Welche Argumente?
(26.01.2019, 10:29)pege78 schrieb: ist das in einer Zelle so überhaupt machbar?
Klar.

Zeig doch mal Deinen bisherigen Ansatz. Schön wäre statt einem Bildchen eine richtige Excel-Datei, dann braucht hier niemand irgendetwas nachbauen.
Gruß
Michael
Antwortento top
#3
Hi,

das nächste Mal bitte keine ScrShots, sondern eine Beispieldatei. Diesmal habe ich sie noch nachgebaut:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
1EinAusDauer
210.01.201924.01.201914
315.10.201831
420.07.201812.01.201912

ZelleFormel
C2=WENN(B2="";MONATSENDE(A2;0)-DATUM(JAHR(A2);MONAT(A2);1)+1;WENN(MONAT(A2)=MONAT(B2);B2-A2;DATEDIF(DATUM(JAHR(B2);MONAT(B2);1);B2;"d")+1))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.zitate.net
Antwortento top
#4
Na gut, wollte den OP noch ein bisschen Eigeninitiative zeigen lassen ... Dodgy
Gruß
Michael
Antwortento top
#5
Hi Michael,

normalerweise schon. Allerdings lässt bereits die Fragestellung keinen anderen Schluss zu als dass der TE ganz am Anfang seiner XL-Kenntnisse steht. Und ich mag deine keine ellenlange Threads, in denen man nicht zum Kern kommt.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.zitate.net
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Der Steuerfuzzi
Antwortento top
#6
Da ich mir schon die Arbeit gemacht habe:
Code:
=WENN(C7="";$B$1;MIN($B$1;C7))-MAX(TEXT($B$1;"""1"".M.JJ")-1;A7)
Gruß
Michael
Antwortento top
#7
Vielen Dank für die Mühe,  habe es über 3 zusätzliche Spalten berechnet und nicht geschafft das in einer Berechnung.

Beginne erst mit Excel.
Antwortento top
#8
Hi,

hast du denn überhaupt die Lösungsvorschläge ausprobiert? Zeige doch mal anhand einer Beispieldatei, was du bisher gemacht hast.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.zitate.net
Antwortento top
#9
sheet 1 - deine Version
sheet 2 deine Version in meiner Tabelle
sheet 3  meine Version Smile


Angehängte Dateien
.xlsx   excel2.xlsx (Größe: 14,73 KB / Downloads: 5)
Antwortento top
#10
Bei Versuch2:
Code:
L4 =WENN(H4="";$L$1;MIN($L$1;H4))-MAX(TEXT($L$1;"""1"".M.JJ")-1;B4)
Gruß
Michael
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste