Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Berechnung, Hilfe!!
#1
Hallo,
Ich habe ein Problem und stehe auf dem Schlauch. Also ich habe in Zelle 1 ein Datum der Einstellung im Betrieb in Zelle 2 ein Datum welches z. Bsp der heutige Tag ist. In Zelle 3 soll nun die Differenz in Jahren sowie den Tagen ( Bsp. 2 Jahre 57 Tage) in Zelle 4 soll dann je nach Ergebnis der Zelle 3 eine Zahl zwischen 1 und 6 ausgegeben werden welche variabel nach  Abstufung  sein soll.

Siehe Anhang

Kann mir jemand helfen???
Danke
Antwortento top
#2
Hi,

du musst deine Datei auch noch hochladen. Rechts (folge dem Pfeil) ist noch ein Button.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
So hier mal der Anhang den ich oben werähnt habe. Ich hoffe man kann damit etwas anfangen.


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#4
Hallo,

was sollen die Helfer mit einem Bild anfangen? Bitte eine .xlsx mit händisch eingetragenem Wunschergebnis hochladen.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
(21.07.2020, 19:58)WillWissen schrieb: Hallo,

was sollen die Helfer mit einem Bild anfangen? Bitte eine .xlsx mit händisch eingetragenem Wunschergebnis hochladen.
Ohh, ok. Mache ich morgen mal ein Beispiel fertig. Sorry
Antwortento top
#6
Hallöchen,

ich gehe mal davon aus, dass Du die Anzahl Jahre und Tage selber hinbekommst?

Die jeweilige Stufe bekommt man mit INDEX und VERGLEICH. Dazu erstellst Du (ggf. zusätzlich) eine Übersicht mit den Anfangszahlen der jeweiligen Stufe. Los geht es mit 0, und am Ende nimmst Du noch 99 oder was auch immer, damit die letzte Stufe auch korrekt zugeordnet werden kann. Du kannst es natürlich noch aufhübschen indem Du das Endjahr daneben schreibst (in die Nachbarzellen), also 0 und 1,999 / 2 und 4,999 / usw. Den Zeitraum ermittelst Du dazu als Dezimalzahl.

Arbeitsblatt mit dem Namen 'Tabelle2'
ABCDE
1s102,6s2
2s22
3s35
4über 599

ZelleFormel
E1=INDEX(A1:A4;VERGLEICH(D1;B1:B4;1);1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#7
so, hier nun mal das was ich meine in einer Tabelle.
Sorry ich bin echt zu blöd. Excel ist nicht so mein Programm.


Angehängte Dateien
.xlsx   Muster.xlsx (Größe: 10,25 KB / Downloads: 3)
Antwortento top
#8
Hallo,

z.B. so:
Arbeitsblatt mit dem Namen 'Tabelle1 (2)'
ABCDEFGHI
1mit DatedifJahreStufe
2NameBeginnvariables DatumDifferenz JahreDifferenz TageStufe0Stufe 1
3Paul01.11.201301.05.20206181Stufe 31Stufe 2
4Max01.03.200601.05.20201461Stufe 54Stufe 3
58Stufe 4
612Stufe 5
717Stufe 6

ZelleFormel
D3=DATEDIF(B3;C3;"Y")
E3=DATEDIF(B3;C3;"YD")
F3=SVERWEIS(D3;$H$2:$I$7;2;1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

oder so:
Arbeitsblatt mit dem Namen 'Tabelle1 (3)'
ABCDEFGHI
1mit BRTEILJAHREJahreStufe
2NameBeginnvariables DatumDifferenz JahreStufe0Stufe 1
3Paul01.11.201301.05.20206,496919918Stufe 31Stufe 2
4Max01.03.200601.05.202014,16773134Stufe 54Stufe 3
58Stufe 4
612Stufe 5
717Stufe 6

ZelleFormel
D3=BRTEILJAHRE(B3;C3;1)
F3=SVERWEIS(D3;$H$2:$I$7;2;1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Gruß
Fred
Antwortento top
#9
Super und Ganz Vielen Dank.

Das hilft mir ein ganzes Stück weiter!!
Antwortento top
#10
Moin,

bitte nicht unnötig vollzitieren. Vor allem, wenn es sich auf den unmittelbar vorherigen Beitrag handelt.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste