Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Berechnung Arbeitszeit
#1
Hallo,
wie kann ich (als Anfänger) folgendes einfaches Problem lösen: 
In einer Tabelle zur Arbeitszeit-Berechnung gebe ich folgendes ein:

Kommen:   Gehen:   Gesamt (h)   Delta  (= Gesamt-Soll(=8h))
7:30         16:45       9:00             1:00 
8:45         16:10       7:25            #################

Die Gesamtstundenzahl ergibt sich aus 'Gehen' - 'Kommen' 
Delta ist Gesamtstundenzahl minus der erforderlichen Arbeitsstunden (8:00)

Wird das Delta negativ bekomme ich eine '##########...' Anzeige. 
Das sollte aber Fehlstunden, also negativ und vorzugsweise rot anzeigen. 
Wie kann ich das lösen? 

Danke!
Axel
Antwortento top
#2
Hi Axel,

dann stell deine Gesamtstundenzahl und dein Delta als Dezimalzahl dar. Damit kannst du auch negative Zeiten darstellen.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallo WillWissen,
das hab ich kurz probiert - also nur das Zahlenformat auf 0,00, dann erhalte ich aber unsinnige Werte.
Die Datei habe ich mal angehängt. 

Gruß,
Axel

Anlage:
.xlsx   Arbeitsstunden_Test.xlsx (Größe: 12,2 KB / Downloads: 8)
Antwortento top
#4
Hallo Axel,

du musst noch rechts den Button "Attachment hinzufügen" anklicken.

Aber ich habe dir mal etwas gebastelt:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
1kommtgehtgesamtdelta kumuliert 0,5Soll: 8,0
208:0016:0080,0
308:3016:007,5-0,5
408:3017:3091,0

ZelleFormatWert
D1"delta kumuliert "0,00,499999999999996
E1"Soll: "0,08

ZelleFormel
D1=SUMME($D$2:$D$25)
D2=C2-$E$1
C2=(B2-A2)*24
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
Hallo WillWissen,
besten Dank, das funktioniert. 
Noch eine Frage: 
In der Monatsübersicht sind auch Samstag, Sonntag und evtl. Feiertage oder Abwesenheitstage. 
Da habe ich dann keine Kommen bzw. Gehen - Buchungen.
Wie kann ich dann die Ausgabe von Minusstunden vermeiden? 

Neue Tabelle hängt an. 

Gruß,
Axel


Angehängte Dateien
.xlsx   Arbeitsstunden_Test2.xlsx (Größe: 12,25 KB / Downloads: 8)
Antwortento top
#6
Da empfehle ich Dir eine Wenn Formel.

in G4: =WENN(UND(D4="";E4="");"";F4-$G$3)

Gruss
Fire
Antwortento top
#7
Moin Axel,

dann erweitere die Formel:
Zitat:=F4-$G$3*(D4<>"")
Du hast jetzt jede Menge Nullen. Falls sie dich stören, kannst du sie mit dem benutzerdef. Format

Zitat:0,0_ ;[Rot]-0,0;;

ausblenden.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
Hallo,
In meinen Augen ist de Lösung unlogisch. Warum wird Zelle $D$3 ( 8 Stunden) abgezogen, wenn anschließend nchts abgezogen werden darf? Verwende Worte, oder Buchstaben um die Zahlen auszuschließen. So wie Frei für Frei, U für Urlaub, G für Gleittag ... Wenn ich einfach nicht zur  Arbeit komme (keine Stempelzeit) wird sonst ja nichts abgezogen.

Gruß
Marcus

Ein Beispiel aus einer sehr komplizierten Abteilung hänge ich an. Da gibt es noch bezahlte Stunden, ohne Dienstleistung, weil die an einem Tag 2 mal arbeiten müssen. Habe sonst nichts in meinem Fundus gefunden (muss ich mich mal neu dran geben).


Angehängte Dateien
.xls   Sachse3.xls (Größe: 20,5 KB / Downloads: 7)

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#9
Hi Marcus,

ich glaube, da hast du etwas missverstanden. Es wird lediglich die Differenz der gearbeiteten Stunden mit den Sollstunden berechnet. Wird über das Soll hinaus gearbeitet, sind es Plusminuten oder -stunden, bei geringerer Arbeitszeit enstprechend Minusminuten oder -stunden.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#10
Hallo Günter,
Minusstunden werden aber doch nicht berechnet ... Bei Minus bleibt alles auf 0 stehen ... Also ich verstehe es wohl wirklich nicht. Klinke mich somit aus, werde aber weiter verfolgen.

Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste